Page 1 of 9 1 2 3 ... LastLast
Results 1 to 10 of 87
  1. #1
    GTLaser's Avatar
    Join Date
    Aug 2009
    Location
    MD
    Posts
    330

    Just got shafted on a used ski... NEED HELP!!!!

    So I drive about 3 1/2 hours to check out a GP1200R with a few goodies. The kid is the second owner and is selling bc he picked up a Turbo Honda. Ski was clean, started up right away, compression straight for all three and seemed like an honest person. He swore nothing was wrong and I told him if there was I would just bring it right back and he had no issue. Drove home with it ( my first Yamaha ), this was Friday night, and decided to take it out today, started but wouldn't go anywhere. Pulled it out of the water, ran it under the hose and didn't see any water coming out of the nozzle ( on my seadoo it does, not sure about Yamaha's ) and I got under the ski and could turn the shaft with my handle very easily, is this normal for Yamaha's? I called up the guy and he agreed to return my money if I brought it back tonight, which I did. Guess what happens when I get there after a 4 1/2 hour drive in Turnpike traffic, his Dad comes out yelling and screaming telling us to get off his yard and calls the police. He said we were trying to scam them. Well cops come, actually tell him to go in his house bc he wouldn't shut up, took my info and said good luck. So I have read a lot here and I know there are Yamaha experts on this forum. I am asking for any advice/knowledge to what it could be and possibly how to fix. Anything would help.


  2. #2
    32 Valves To Love! Racecar_Dave's Avatar
    Join Date
    Jul 2009
    Location
    Alum Creek
    Posts
    635
    +1
    2
    You should have taken the Pigs and the Dad to the water to show them that YOU were ripped off.

    Sorry to hear that.

    Now when you "ran it under the hose" does that mean you hooked up the flush hose? When I Flush my ski I dont think anything comes out of the pump, cant remember, it pours out the intake grate and the two holes on the side of the boat up by the handle bars I know that for sure.

  3. #3
    GTLaser's Avatar
    Join Date
    Aug 2009
    Location
    MD
    Posts
    330
    Quote Originally Posted by Racecar_Dave View Post
    You should have taken the Pigs and the Dad to the water to show them that YOU were ripped off.

    Sorry to hear that.

    Now when you "ran it under the hose" does that mean you hooked up the flush hose? When I Flush my ski I dont think anything comes out of the pump, cant remember, it pours out the intake grate and the two holes on the side of the boat up by the handle bars I know that for sure.
    Yeah, Pigs just wanted to get out of there bc they couldn't stand his old man. The kid and his old man claimed I sucked something up and just wanted my money back, they didn't even want to look over the ski.

    Under the hose I mean with flush hose hooked up. It does the same, water out the grate and out the sides. I guess I'm used to the seadoos. So the main problem is that I am not getting any propulsion in the water. Any ideas?

  4. #4
    GTLaser's Avatar
    Join Date
    Aug 2009
    Location
    MD
    Posts
    330
    double post

  5. #5
    All hail the Chief! fullboogie's Avatar
    Join Date
    Nov 2005
    Location
    Texas
    Posts
    3,155
    +1
    44
    You've got stripped splines on either the pump shaft or the mid shaft. Relatively easy fix, and not too expensive. Pull the pump and inspect.

  6. #6
    Buaidh No Bas howestek's Avatar
    Join Date
    May 2005
    Location
    Louisiana
    Posts
    917
    You could turn the drive shaft VERY easy? With the plugs in?

    edit : Fullboogie beat me to the punch.

  7. #7
    GTLaser's Avatar
    Join Date
    Aug 2009
    Location
    MD
    Posts
    330
    Quote Originally Posted by fullboogie View Post
    You've got stripped splines on either the pump shaft or the mid shaft. Relatively easy fix, and not too expensive. Pull the pump and inspect.

    Will do. Stripped splines implies that it wore out correct? The ski has 197 hours on the hull. How often do the splines go? I couldn't even move the damn thing an inch, absolutely no propulsion which is why I believe that the kid new perfectly well that the ski had an issue. The shitty part of it is that the kid seemed pretty genuine, but I guess those are the best artists. This will most likely go to court. I'm not a petty person at all, but when someone says that the ski runs perfectly fine, i drive 3.5 hrs each way to pick it up. Then the ski is a lemon and I call back, the guy offers my money back. I drive another 3.5 hrs there to step out of the truck and have the kid's dad screaming his head off telling us to get the f of his property and calls the cops(literally when I stepped out of the truck). We said go ahead! Cop told us shit like this happens all the time, sympathized with us, but said sorry we have to settle this in court. So 3.5 hrs back with no money. No problem with me, I'll get it back in court somehow. I'm actually on the way back now, still an hr away from home posting with my aircard.

  8. #8
    GTLaser's Avatar
    Join Date
    Aug 2009
    Location
    MD
    Posts
    330
    Quote Originally Posted by howestek View Post
    You could turn the drive shaft VERY easy? With the plugs in?

    edit : Fullboogie beat me to the punch.
    yep, first thing I did was test the shaft and inspect the impeller. I got under the trailer and had my buddy fire her up. The shaft and impeller were spinning. Shut her down and tried to turn it by hand with surprising ease. So under load in the water I guess it spins at an extremely low rate or not at all. This being with the motor revved to 5-6k just to make sure and it felt the same as if I was giving it throttle out of the water.

  9. #9
    32 Valves To Love! Racecar_Dave's Avatar
    Join Date
    Jul 2009
    Location
    Alum Creek
    Posts
    635
    +1
    2
    wear ring, maybe?

  10. #10
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Pull the pump and if you don't see anything obvious get us some pics of the splines on the shaft, pump, impeller, and anything else...

Page 1 of 9 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New to Greenhulk and skis - Just got myself a nice xlt1200 but needs TLC!
    By Bigwilk in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 06-07-2012, 07:35 AM
  2. just got a 94 waveraider 700 and need help please
    By shaun23a11en in forum Yamaha Old School Skis
    Replies: 10
    Last Post: 05-17-2012, 10:13 AM
  3. Just got my Riva reducer nosel and need advise
    By cwilliams21 in forum 4-Tec Performance
    Replies: 9
    Last Post: 03-18-2010, 11:17 AM
  4. Input on purchasing used ski.
    By Tuner Inside in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 09-02-2008, 06:19 PM
  5. What to look for on a used ski??
    By Mac Daddy Racing in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 03-19-2008, 05:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •