Results 1 to 2 of 2
  1. #1

    06 RXP Died....NO Power to startup

    Took the rxp out for a final sunday ride yesterday, started fine, got a 12V low error but all seemed well. I went about 300 feet from the dock so that I could turn it around and come back in, and i went to adjust the trim to the center position and as soon as I touched the VTS button, the ski died. So I remove and reinstall the lanyard, nothing, no beep, no display. Checked the main fuses as it was getting dark, and they seemed fine. I put a new battery in and it did the same thing. what could have caused this? any help would be greatly appreciated.

  2. #2
    start at the begining check your ground strap

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. HELP! 06 RXP loss of power!
    By IanuR1 in forum 4-Tec Performance
    Replies: 25
    Last Post: 09-09-2013, 06:20 PM
  2. rxp has no power from battery need help
    By pbrxp in forum 4-Tec Performance
    Replies: 29
    Last Post: 08-06-2010, 08:03 PM
  3. FS RXP-RXT Exhaust Power Pipe
    By ADAMBOMB in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 06-28-2010, 03:26 PM
  4. help 05 rxp loss of power
    By MuffSquad in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 06-08-2009, 11:18 PM
  5. Replies: 6
    Last Post: 07-06-2008, 09:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts