Results 1 to 2 of 2
  1. #1

    1996 slx780 drive coupler

    My 1996 polaris slx780 is making a scraping noise when its in the water. I can not get the pwc 25mph. I thought I had something stuck in the jet pump but it looks ok. I think the drive coupler is slipping. I had it on the lake and at certain times I can start off fine and then it hit a certain speed and the noise comes back. I will also have where it must stop slipping and it will race up and run fine for several seconds.
    Is there a way to check this coupler the pwc ha sonly 34 hours on it?

  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    I replied in your ther post about it.

    Have you also checked your impeller to wear ring clearance and pump bearings?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 polaris slx780 drive system
    By polarisman in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 11-13-2009, 09:39 AM
  2. 97 SLTX drive coupler remove
    By bmill in forum Polaris Open Discussion
    Replies: 6
    Last Post: 10-18-2007, 09:39 AM
  3. 95 SLT 750 drive coupler
    By SharkCrazy in forum Polaris Open Discussion
    Replies: 8
    Last Post: 06-26-2007, 11:12 PM
  4. 1997 SL800 / 1996 SLX780 Upgrades
    By rickreeves1 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-18-2007, 01:59 PM
  5. aligning drive coupler
    By dhoad in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 04-19-2007, 07:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts