Results 1 to 6 of 6
  1. #1

    Join Date
    Jul 2008
    Location
    Peterstown, WV
    Posts
    100

    Vts quit working how to fix it??

    Well I started up my ski and noticed the bar beside trim wasn't there. It flashes when it is started than goes away. However, I see the depth finder flashing now. Do I have to take this to the dealer to get it fixed or what?


  2. #2
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    what year sea-doo?

  3. #3
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by castiljd View Post
    Well I started up my ski and noticed the bar beside trim wasn't there. It flashes when it is started than goes away. However, I see the depth finder flashing now. Do I have to take this to the dealer to get it fixed or what?
    Unfortunatley... yes You need the B.U.D.S software treatment.

  4. #4

    Join Date
    Jul 2008
    Location
    Peterstown, WV
    Posts
    100
    That is what I figured. Anyone know what that cost? Sorry, I did not mention. 2006 RXP.

  5. #5
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    This is happening on a weekly basis it seams here lately... most have had it repaired for under a $100 bucks. Most dealers will probably charge you for at least one hour of there normal labor rate maximum... maybe less!

  6. #6
    Quote Originally Posted by bigdaddyRXP View Post
    This is happening on a weekly basis it seams here lately...!
    Ya think? bet ya your next .....or maybe me

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. VTS Function FiX GTX 215.... Anybody know How to fix this????
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 02-12-2015, 09:21 AM
  2. Straight pipe and how to make it work on a 15f
    By smokeysevin in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 09-23-2012, 03:10 PM
  3. STX-R Leaking - Your opinion as to how to fix it
    By tua79610 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 12
    Last Post: 08-28-2012, 01:57 PM
  4. L Temp not working right? How to Fix
    By flnsx in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-13-2012, 12:00 PM
  5. sl750 hood wont unlock, how to fix it?
    By 87r in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 07-20-2011, 03:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •