Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    upsetting gps numbers

    so ive been battling oil problems with my 07 rxt just changed plugs, compression test and oil change, the thing feels great speedo says 70 at 7600 rpms my gps on my iphone (not sure if its accurate) said 62, my prop and wear ring are mint i have (riva) intake,water box, thru hull, wedge, stage 1r prop, pro opas, catch can, gen2 wheel, intake grate, my compression was 140 150 150 any clues? i thoguht the ski stock did faster


  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by salerngo47 View Post
    so ive been battling oil problems with my 07 rxt just changed plugs, compression test and oil change, the thing feels great speedo says 70 at 7600 rpms my gps on my iphone (not sure if its accurate) said 62, my prop and wear ring are mint i have (riva) intake,water box, thru hull, wedge, stage 1r prop, pro opas, catch can, gen2 wheel, intake grate, my compression was 140 150 150 any clues? i thoguht the ski stock did faster
    Your rpms are low. I would start by getting rid of that riva bov.

  3. #3
    Banned User
    Join Date
    Aug 2007
    Location
    Reading PA
    Posts
    1,670
    yeah i agree ditch the BOV, u got something going on there cause with a 14/17r u should be able to turn that with out any mods just fine, my buddy ran that prop with an intake grate for a year no prop with no other mods.

  4. #4
    PEST!'s Avatar
    Join Date
    Jun 2008
    Location
    Rockledge Florida
    Posts
    768
    Get a real GPS. The Iphone is a bit slow to update speed. Is you oil level right. Run 30 seconds at idle level and the level should be middle of the marks. To high low Rpm and oily air fed to the engine. 7600 is to low.

  5. #5
    Banned User
    Join Date
    Aug 2007
    Location
    Reading PA
    Posts
    1,670
    Quote Originally Posted by PEST! View Post
    Get a real GPS. The Iphone is a bit slow to update speed. Is you oil level right. Run 30 seconds at idle level and the level should be middle of the marks. To high low Rpm and oily air fed to the engine. 7600 is to low.

    +1 on the Get a real GPS. Iphone is not very good for speed my wifes is about 4 to 5 mph slower then my Pioneer.

  6. #6
    yea i know the iphone wouldnt be that accurate i figured it be better than the speedo, i run the same rpm with or without the bov ive tried both, i did notice my intake grate sits a tad below the ski could that be a big problem? i dont think that would effect the rpms

  7. #7
    captain slow Turbo Retro's Avatar
    Join Date
    Jun 2007
    Location
    Australia - perth
    Posts
    1,679
    +1
    164
    supercharger slip or leaky boost hose????

  8. #8
    Quote Originally Posted by retro_racer View Post
    supercharger slip or leaky boost hose????
    just had the washers and the gen2 put in at the dealer, they should have checked the slip right? and where should i look for a boost leak i appriciate all the help hopefully i can figure this out without emptying my pockets

  9. #9
    Banned User
    Join Date
    Aug 2007
    Location
    Reading PA
    Posts
    1,670
    get a real gps first before u start pulling ur hair out, u might not have a problem at all.

  10. #10
    Doel Tiburon1264's Avatar
    Join Date
    Nov 2007
    Location
    Jacksonville, Florida
    Posts
    2,343
    +1
    11
    Quote Originally Posted by salerngo47 View Post
    just had the washers and the gen2 put in at the dealer, they should have checked the slip right? and where should i look for a boost leak i appriciate all the help hopefully i can figure this out without emptying my pockets
    First get the BOV out. I read those Riva BOV leaks. You want a good BOV setup send PM to Turbo Tech PR. What IC you running? I don't see one in your Mods. if you going to install IC get a XS or Gen II that would give you 200rpm's. Get a real GPS. I hope you not running those Denso spark plugs they SUCK go with originals they work great. If you list all your mods, I know we can help you out. I have a big problem with my sick and thanks for the forum members the problem was solve with not spending no cash........Good luck! Salerngo47. If you want some pics of my BOV setup let me know.

    This is what Turbo Tech PR did to my ski. Malvin and Team did a great job installing the BOV and Flange on my Riva Gen II IC Pipe. Thanks Malvin for your great job.
    Attached Thumbnails

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Finally got some GPS numbers, and dissapointed.
    By PuprleNuprleGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 22
    Last Post: 07-24-2006, 09:11 AM
  2. GPS numbers not where I want them to be
    By Chezzy in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-07-2006, 07:00 PM
  3. got some gps numbers today ?
    By txgp1300r in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 06-03-2006, 10:26 PM
  4. Finally got some GPS numbers on Carey's ski
    By Green Hulk in forum 4-Tec Performance
    Replies: 7
    Last Post: 03-20-2006, 07:45 AM
  5. Better GPS numbers with no changes?
    By rx4pain in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-31-2005, 01:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •