Results 1 to 10 of 10
  1. #1
    FLjoyrider's Avatar
    Join Date
    Jul 2007
    Location
    Florida
    Posts
    555

    07 4 tec overheat

    have an 07 4 tec that runs great, but once in awhile it overheats, mostly while idling but occasionally while cruising. Checked the coolant, its good, checked to make sure the thermostat was opening and both lines are hot on the water pump once it gets up to temp.. intercooler is the ride plate..? and can't see how anything could go wrong with that.. Looking for some tips, going to check out the temp sensor tomorrow to make sure thats not fried.


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    What Kind of overheating is going on??Engine or exhaust?

  3. #3
    FLjoyrider's Avatar
    Join Date
    Jul 2007
    Location
    Florida
    Posts
    555
    probably a dumb question - - new to these newer seadoo's.. but how do you tell the difference between exhaust or engine overheat?

  4. #4
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,759
    +1
    29
    My just says Hi-Temp.

  5. #5
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    If its exhaust it will read "Exhaust" on the dash and will flash a code..
    If its engine it usually will flash "E-temp" with a code also..

  6. #6
    FLjoyrider's Avatar
    Join Date
    Jul 2007
    Location
    Florida
    Posts
    555
    Just says hi-temp.. maybe hit set five times to pull the code??

  7. #7
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by FLjoyrider View Post
    Just says hi-temp.. maybe hit set five times to pull the code??

    That is usually engine..A code would definatly tell us what it is...

  8. #8
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    I don't think the newer skis have a Set button. I think that a dealer has to read the code... Ron

  9. #9
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by King_Of_Fun View Post
    I don't think the newer skis have a Set button. I think that a dealer has to read the code... Ron

    Correct Ron...06 and up does not have a mode button..If he cannot get the code to re-appear then he will have to take it to the dealer and have them hook it up to the buds system..

  10. #10
    xBigDaddyx117's Avatar
    Join Date
    Oct 2008
    Location
    Florida
    Posts
    366
    sounds like a water pump but I dont know how reliable these are, I dont think they mess up that much.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SOLD 07 4-TEC Bare Cylinder Head
    By YamahaManny in forum Sea Doo Classifieds
    Replies: 6
    Last Post: 02-11-2014, 08:54 AM
  2. '07 GTI 4 tec leaks
    By [email protected] in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 06-07-2010, 09:02 PM
  3. FS 4-TEC Waterbox 02-07 w/ temp sensor
    By Kohl531 in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 09-26-2009, 06:58 PM
  4. 03-07 4 tec drive shaft 60.00 shipped
    By marc777 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 09-26-2008, 06:38 AM
  5. 2005-07 d-plate and overheat warning?
    By Suthrn in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 01-18-2007, 05:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •