Results 1 to 7 of 7
  1. #1

    Used Polaris, should I be conserned!

    How bad are the electrical problems?
    I can get my hands on a 2001 Virage TX for cheap.
    It seams to run good?
    Should I be conserned?
    Is there anything I can do to make it reliable?


  2. #2
    I also want to bring up that the previous guy hit a rock aand put a hole near the rear of the boat.
    Can this be repaired?
    Should it?
    Has anyone done it?
    I know these were not fiberglass.
    Or, should I walk away!
    I can get it with 65 hours, a trailer for $1200.???

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Do you have pictures of the damage?

    The SMC hull material in a Virage can be repaired, but the extent of the damage, and the condition of the rest of the machine would determine what value it has.

    How do you know if it runs well - have you ridden it on the water?

    Cylinder compression numbers?
    Engine hours?

    This might be helpful;
    Basic Introduction to the purchase of a Personal Watercraft

  4. #4
    2001 virage tx bossdog67's Avatar
    Join Date
    Jul 2009
    Location
    saskatchewan , canada
    Posts
    174
    i have the 2001 tx . and i love it . but if you can, get this thing to the water , on a trailer , and run it !! 15 minutes if you can . a lot can happen to show you what may or may not be wrong . i know it has a hole , but if you can leave it on trailer and run it i would . and play with the throttle , run it up to 45oo rpm , and hold it for 2 minutes !!

    just my opinion


    KENT

  5. #5
    When I run it, what should I look for?
    Do I have to take it to water?
    Don't Polaris have a hook up for a hose?
    The hole is 3" and near the rear.
    How do you fix the hole? Tigerhair? Epoxy?

  6. #6
    Do you guys have a lot of reliability problems. I hear Polaris have electrical problems.
    By the way the guy said he got an estimate to fix the haul, it would cost around $1200.
    ???

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by wojo14 View Post
    When I run it, what should I look for?
    Do I have to take it to water?
    Don't Polaris have a hook up for a hose?...
    The reason for taking it to the water is so you can strap it to the trailer, back it into the water until the jet pump intake is submerged, then run the engine under load.

    You can even open up the throttle to full power on the trailer, just make sure the bow is strapped DOWN, and the tow car is fully braked to resist the pump thrust.

    You will not see maximum possible RPM this way, since the hull is not moving through the water, but you should see smooth engine running at all RPM levels. This is similar to what dealerships do with their 'test tanks'.

    For your launch ramp engine testing, you can stuff the hole in the hull with some foam to reduce the water leakage.

    For testing in your drive way, you can add a reverse flush connection to the water manifold bar, but it is better to directly connect the garden hose to the 3/4" water inlet feed from the jet pump, located down low on the right hand side of the pump base.

    Disconnect the hose from the pump base, insert a 3/4 barb to garden hose adapter.

    On the hose, the jet pump will not be under load, so your engine testing will be more limited;

    Engine start, THEN water on
    Water OFF, then engine off.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MSX 110 bad PPU assembly JUNK! Polaris should be ashamed!
    By KCwatercraft in forum MSX/Matrix
    Replies: 32
    Last Post: 06-10-2016, 10:35 AM
  2. 96 gti, how much oil should it be using? can you pre mix?
    By rocksandblues in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-10-2013, 07:35 AM
  3. Should i be using efi cleaner.
    By willie in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 07-15-2012, 09:13 AM
  4. gp1200r .... modd'd .. what prop should i be using...
    By 00gp1200r in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 04-15-2011, 08:07 AM
  5. off on switch SHOULD IT BE USED OR not?
    By noshowallgo in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 10-10-2008, 12:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •