Results 1 to 3 of 3
  1. #1

    Starter issues...first ski...first post!

    hey fellas this forum is so awesome lots of good info for us newbs! 93 Polaris SL 750 with a starter "click" issue...pulled the starter is tested good...easy ways to test things from there...any help would be awesome!

  2. #2
    2001 virage tx bossdog67's Avatar
    Join Date
    Jul 2009
    saskatchewan , canada
    did you check the solinoid ?? the click kind of sound like that may be your issue . follow the pos wire from battery , it should connect to it !! may be in your electrical box !!!

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada

    Confirm that the battery is actually good.

    Connect multi-meter to battery, watch voltage when Start button is pressed. If battery voltage drops below 10.6 volts with Start button pressed, battery is not good.

    Click below for more useful info

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. please help first ski, and having issues
    By scd2747 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 02-25-2012, 12:31 AM
  2. First Ski 91 650 Manual & Pisser issue
    By Digitish in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-12-2010, 07:16 PM
  3. 2007 GTX oil change, First ski
    By alrock in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 07-23-2007, 02:08 PM
  4. slt 750 first ski! newbie!
    By 1bad69chevelle in forum Polaris Open Discussion
    Replies: 25
    Last Post: 03-13-2007, 12:16 PM
  5. Purchased First Ski Today! (RXP)
    By AMG ETR in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 05-19-2006, 09:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts