Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    MSX 150 Surges at idle between 3150 and 3550 RPM's

    I took my MSX 150 to a shop and they kept it for 5 weeks and when I took it there hte problem was it would not Rev past 2900 RPM's. THey told me they never firgured out what the issue was but now it surges at idle between 3150 and 3550 RPM's in reverse. In forward the motor goes past 6700 RPM's. The oil level is fine. I have checked the intercooler for oil buildup and there is none. I check the MAP sensors for Ohms and they are in range according to the spec sheet.

    Does anyone have any ideas?
    Last edited by rtburns; 08-15-2009 at 08:23 PM.


  2. #2
    2&4strokepolaristech's Avatar
    Join Date
    Aug 2006
    Location
    Oswego,NY
    Posts
    919
    +1
    6
    do you have any check engine lights on?

  3. #3

    MSX 150 Surges at idle between 3150 and 3550 RPM's

    No Check engine light.

  4. #4
    2&4strokepolaristech's Avatar
    Join Date
    Aug 2006
    Location
    Oswego,NY
    Posts
    919
    +1
    6
    what is your MAX RPM?

  5. #5
    I start it in reverse because if I start it in forward it runs at about 6500 RPM's. Not sure why it is run away mode but.

  6. #6
    I shut it down before it tops out or throw it back in Reverse.

  7. #7

    Update

    Today I checked the all the sensors with the exception of the speed sensor and all of them are within the specs of given on the spec sheet. I even checked the ETB and it checked to be within the specifications as well. It almost seems like there is an issue with the ETB not closing all the way. Just wondering if the DC motor in the ETB is maneuvered (controlled) both ways by the wireless control? When I let off the throttle cable it does not sound like the motor is working it just seems like the spring control is closing the Venturi. If I force the venturi all the way closed then let go it seems the motor will idle but if I use the throttle any it will not return to idle. I wish I had a ETB to compare it to to see if it works the same way.

    ANy ideas?

  8. #8
    2&4strokepolaristech's Avatar
    Join Date
    Aug 2006
    Location
    Oswego,NY
    Posts
    919
    +1
    6
    are you running this unit out of the water or in the water?

  9. #9
    Out of the water with water running to the unit.

  10. #10
    Before I took it to the shop it idled fine. Can the Digital wrench change the idle parameters?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 MSX-150 Surges and MAX RPM 5850
    By rcsscraig in forum MSX/Matrix
    Replies: 37
    Last Post: 09-09-2015, 06:53 AM
  2. Replies: 39
    Last Post: 09-16-2010, 09:33 PM
  3. 03 msx 140...dies at idle..plz help!
    By durkinz in forum MSX/Matrix
    Replies: 49
    Last Post: 06-10-2009, 05:16 PM
  4. Engine surging at idle, possible causes?
    By 01xdime in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 07-05-2007, 10:42 PM
  5. Surging at idle w/ RR whell and 42's? Normal?
    By Water4fire in forum 4-Tec Performance
    Replies: 25
    Last Post: 04-10-2007, 07:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •