Results 1 to 4 of 4
  1. #1

    Intermittant function for forward/reverse

    Hi All,

    I have a Genesis 2003. The forward/reverse function works intermittantly when the engine is running. With the engine stopped, forward/reverse work as usual when also holding the bildge switch. This also works when driving but it a PIA . I am sure a relay/solenoid is failing somewhere. Does anyone have some ideas to troubleshoot?

    Thanks,

    Mike


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Welcome to the hulk..
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	03polarismanual.jpg 
Views:	51 
Size:	490.5 KB 
ID:	146096  

  3. #3
    2&4strokepolaristech's Avatar
    Join Date
    Aug 2006
    Location
    Oswego,NY
    Posts
    919
    +1
    6
    Quote Originally Posted by mike c View Post
    Hi All,

    I have a Genesis 2003. The forward/reverse function works intermittantly when the engine is running. With the engine stopped, forward/reverse work as usual when also holding the bildge switch. This also works when driving but it a PIA . I am sure a relay/solenoid is failing somewhere. Does anyone have some ideas to troubleshoot?

    Thanks,

    Mike
    I would replace the L/R module that is located under your mfd. Open your hood. Take out the the screws from the panel that is behind your gauge. It should be there attached to the deck by velcro.It is a little black flat box with a plug in connector.Make sure the connections are clean first and the terminals look like they are in good shape. The L/R module in that boat controls the start/stop function in that boat as well as the bilge and the reverse function as well.It sends power to these two componets when it sees a tach signal.When you press the bilge button you bypass the L/R module and you are manually powering up these circuts. polaris part number 4010724. This should do the trick. Let us know how you made out.

    Jay

  4. #4
    Quote Originally Posted by 4strokepolaristech View Post
    I would replace the L/R module that is located under your mfd. Open your hood. Take out the the screws from the panel that is behind your gauge. It should be there attached to the deck by velcro.It is a little black flat box with a plug in connector.Make sure the connections are clean first and the terminals look like they are in good shape. The L/R module in that boat controls the start/stop function in that boat as well as the bilge and the reverse function as well.It sends power to these two componets when it sees a tach signal.When you press the bilge button you bypass the L/R module and you are manually powering up these circuts. polaris part number 4010724. This should do the trick. Let us know how you made out.

    Jay
    Jay, thanks for the reply. Makes complete sense as now the stop button is occasionally not working as well....

    Will post once I get the new part.

    Mike

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Looking for a reverse bucket spring
    By KirkF350 in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 03-10-2010, 09:54 PM
  2. Looking for a reverse bucket spring
    By KirkF350 in forum 4-Tec Performance
    Replies: 0
    Last Post: 03-09-2010, 09:28 PM
  3. How to remove the forward reverse assembly in a 2003 Polaris Virage
    By Slippery When Wet in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 07-01-2009, 03:00 PM
  4. ?Ideas for lubing reverse cable?
    By ppkarnezis in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 02-26-2009, 01:46 PM
  5. Easy Forward/Reverse Handle Fix
    By tomgtv in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 07-22-2007, 04:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •