Results 1 to 4 of 4
  1. #1
    BLKDOG blkdog's Avatar
    Join Date
    Aug 2007
    Location
    Uncasville, CT
    Posts
    25

    ultra LX gas in oil

    changed the oil and filter , the longer I ran it the better it ran but it still runs rough. tops out 40 mph @7700 rmp.
    Going to change the oil again, maybe twice. Just wondering if I'm missing something esle.
    Any suggestions would greatly be appreiated!


  2. #2
    DWRAT's Avatar
    Join Date
    Sep 2008
    Location
    PHX, AZ
    Posts
    135
    You need to check out your pump area.
    7700 RPMs is good but 40 mph is a pump problem sign.

  3. #3
    is this an 09 ultra lx 260? how much gas in oil? need more info so they can help you out better.

  4. #4
    Ultra4ever drtbk4ever's Avatar
    Join Date
    Feb 2008
    Location
    Edmonton, AB, Canada
    Posts
    196
    +1
    1
    Is that 40 mph on a GPS or on the ski's speedometer. The speedometer are seldom accurate.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Gas in Oil Help, Please - Ultra 250X
    By Dr. Evil in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 06-16-2012, 03:02 AM
  2. Gas-in-oil fiasco
    By SeaDoocer in forum Kawasaki Open Discussion
    Replies: 145
    Last Post: 09-25-2007, 08:23 AM
  3. Ultra 250 Gas in the oil.........what I am doing.....
    By Hurricane1000 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 23
    Last Post: 08-23-2007, 07:44 PM
  4. 250x Smell of Gas in oil.. and heavy white exhaust now present
    By mugmainer in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 08-08-2007, 05:03 PM
  5. How to check for gas in oil?
    By Hecyan in forum 4-Tec Performance
    Replies: 9
    Last Post: 03-14-2007, 07:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •