Results 1 to 9 of 9
  1. #1

    Join Date
    Jun 2008
    Location
    Southington, CT
    Posts
    9

    04 RXP sputtering after landing jumps

    I was out on the water today with my 04 RXP and the ski runs great until you land a jump and the hull slams. If the ski just hops out of the water there is no issue but if it slams down hard the motor starts to bog down and sputter. It feels like there is a rev limiter at 3K RPM. If I let off the throttle for a sec and get back on it smoothly it will clear out. If It starts to sputter and I got WOT it will just keep sputtering... Any ideas?


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    The RXP is not designed to be a jumper... buy an XP for that crap

  3. #3
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by mlidzct View Post
    I was out on the water today with my 04 RXP and the ski runs great until you land a jump and the hull slams. If the ski just hops out of the water there is no issue but if it slams down hard the motor starts to bog down and sputter. It feels like there is a rev limiter at 3K RPM. If I let off the throttle for a sec and get back on it smoothly it will clear out. If It starts to sputter and I got WOT it will just keep sputtering... Any ideas?
    Its normal. The TOPS sensor puts it into limp mode. The hard slams trick the sensor.

  4. #4

    Join Date
    May 2009
    Location
    Virginia Beach, VA
    Posts
    119
    +1
    2
    I have a new rxp-x that does the exact same thing. Its pretty sensitive as it doesnt take much to set it off. It sputters for about 3 seconds then its perfectly normal again.

  5. #5
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    Quote Originally Posted by speedskixp View Post
    Its normal. The TOPS sensor puts it into limp mode. The hard slams trick the sensor.
    Yup. Or when the ski gets to a certain vertical angle the sensor begins to cut the engine off. It can be bypassed.

  6. #6
    Your pump could also be filling up with air. You should let off the throttle when you come unhooked and then when you land accelerate slowly and let your pump fill back up with water.

    And I agree, buy an XP or stand up for wave jumping. I did.

    The rxp is good for going fast and thats about it. Fun for what it is but NOT a freestyle ski.

  7. #7

    Join Date
    Jun 2008
    Location
    Southington, CT
    Posts
    9
    Thanks for the help! (except telling me not to jump my ski, thats kind of lame, where I ride its inevitable...)

    What does this sensor do and is it safe to bypass?

  8. #8
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    i jump the crap out my ski going vertical when i can and i've never had any issues, maybe its cause i let off the throttle after i hit the wake

  9. #9

    Join Date
    Jun 2008
    Location
    Southington, CT
    Posts
    9
    Quote Originally Posted by meeper View Post
    i jump the crap out my ski going vertical when i can and i've never had any issues, maybe its cause i let off the throttle after i hit the wake
    I tried both letting off and staying on the throttle and it doesnt matter.

    I didnt have the problem before so Im thinking that sensor needs replacing if its acting up frequently now.

    Most landings dont affect it but its when the hull makes that slam sound that it does it. Sometimes its not even an intentional jump, Ill get caught in the wake of a couple big boats at once and the water drops out from under my ski and it slams.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 02-12-2012, 08:58 PM
  2. 04 rxp sputtering and coughing HELP!
    By Jetskirxp in forum 4-Tec Performance
    Replies: 18
    Last Post: 07-03-2011, 08:39 PM
  3. WTB 04 RXP : opas block offs, after market intake grate, pump wedge...
    By b_dolla44 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 07-24-2010, 04:48 PM
  4. 04 rxp speed after mods ?
    By jetskibill9999 in forum 4-Tec Performance
    Replies: 20
    Last Post: 09-10-2008, 08:42 PM
  5. How To: Install RR ECU after the knock sensor update 04 RXP
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 15
    Last Post: 06-14-2008, 12:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •