Results 1 to 10 of 10
  1. #1
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153

    Prop boot and cavitation

    I was having severe cavitation problems on take off, and I noticed that my RPM's and top speed were down.

    I thought it was my wear ring, as I looked up into the grate with a flashlight and saw a big hole in the wear ring, but no issues with the impeller.

    I took off the pump and I noticed that my rubber prop boot that goes over the drive shaft had flipped over! It was now up against the prop blades themselves.

    so if you suddenly see cavitation out of the hole, and your top speed is down, your RPMs have dropped 200-300, look there at the boot.

    I went back to the Solas aluminum boot


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,428
    +1
    177
    I had the exact same problem with mine once. just bought another $5.oo stock one and no more problems.

  3. #3
    Hondastage1's Avatar
    Join Date
    Jan 2006
    Location
    Dayton Ohio
    Posts
    139
    The rubber boot on the Honda's work well. The aluminum ones work loose and slide up the shaft in just a few hours of run time. The solas and skat trak both have issues in this area.

    Randy

  4. #4
    Resident Jicky Jack Jeff C's Avatar
    Join Date
    May 2005
    Location
    Twin Cities, MN
    Posts
    1,153
    Honda:

    Thanks for the quick reply, I appreciate it.........

  5. #5
    I had similar problems........mine seperated.......similar symptoms......got a new one and all is good
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC04551.JPG 
Views:	166 
Size:	508.9 KB 
ID:	52625  

  6. #6
    250 horses and only one jocky
    Join Date
    Feb 2008
    Location
    London Kent
    Posts
    118
    Quick question........does the solas metal boot fit the Skat Trak? otherwise im going to have to order 1 cheers

  7. #7
    Just to clarify...that rubber cone is on the inlet side of the impeller?? To replace it you would need to remove the impeller right?? Sorry, very new to jet boats and am trying to learn all about them so that I can do my own repairs!!

  8. #8
    Quote Originally Posted by Thor7000 View Post
    Just to clarify...that rubber cone is on the inlet side of the impeller?? To replace it you would need to remove the impeller right?? Sorry, very new to jet boats and am trying to learn all about them so that I can do my own repairs!!
    Yes u have to remove the impeller and the rubber boot screws in the front of it. Keep in mind it is a left hand thread, meaning screwing it to the left tightens it up.

  9. #9
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,620
    +1
    1,192
    Quote Originally Posted by Thor7000 View Post
    Just to clarify...that rubber cone is on the inlet side of the impeller?? To replace it you would need to remove the impeller right?? Sorry, very new to jet boats and am trying to learn all about them so that I can do my own repairs!!
    NO, you do not have to remove the impeller. You do have to remove the pump.

  10. #10
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    5,408
    +1
    614
    Quote Originally Posted by troyheb View Post
    NO, you do not have to remove the impeller. You do have to remove the pump.
    For Thor7000

    Remove the intake grate, just reach in & loosen, then cut the nose cone off with a razor blade or knife......no need to remove the pump. Many here run without a nose cone.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. another prop pitch and r ?
    By VaRedneck in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 04-25-2008, 09:56 PM
  2. What Intake Grate, prop, nozzle, and Ride Plate Do I Buy??
    By stepjl in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 09-13-2007, 06:57 AM
  3. new SS and cavitation...need help!
    By pet in forum 4-Tec Performance
    Replies: 44
    Last Post: 06-17-2007, 09:32 PM
  4. Best place for prop repair and repitch?
    By yellow4 in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-13-2007, 07:52 PM
  5. Prop tools and seals
    By BJTKRXPHD in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-24-2006, 02:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •