Results 1 to 6 of 6
  1. #1

    Join Date
    Aug 2009
    Location
    LI, NY
    Posts
    344
    +1
    3

    98 XLT 760 doesn't restart after riding

    I've got a 1998 XLT760 that is hard starting after shutting down. I have to use the primer to get it restarted.


  2. #2
    DAGO RACING CREW 97GPSLEEPER's Avatar
    Join Date
    Apr 2006
    Location
    Orange, TX
    Posts
    4,228
    +1
    169
    If the carbs have never been rebuilt, it is definetly time being the ski is a 98 model.

  3. #3

    Join Date
    Aug 2009
    Location
    LI, NY
    Posts
    344
    +1
    3
    Ok will do but what about fuel pump and is there some kind of check valve in it and could the carbs be draining out?

  4. #4
    pilo704's Avatar
    Join Date
    Jul 2008
    Location
    dirty jerzz
    Posts
    830
    glen when you do the rebuild your going to replace the check valves in the fuel pump

  5. #5
    DAGO RACING CREW 97GPSLEEPER's Avatar
    Join Date
    Apr 2006
    Location
    Orange, TX
    Posts
    4,228
    +1
    169
    Quote Originally Posted by pilo704 View Post
    glen when you do the rebuild your going to replace the check valves in the fuel pump

    +1

    Does the ski run good besides being hard to start? You can richen your low speed adjustment screws, it may help it start faster. A perfectly tuned low speed circuit should allow it to start without having to give any throttle or choke after the motor is warmed up.

  6. #6

    Join Date
    Aug 2009
    Location
    LI, NY
    Posts
    344
    +1
    3
    Yes it does seem to run well at all times. It is a totally stock ski no mods done. Bought ski last fall. Put about twenty hours on it and then encountered this problem. I'm all for fixing problems but want to know how systems work and figure out what caused it and not just change parts.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bogging on restart after a ride?
    By LivingSlow in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-31-2016, 08:40 AM
  2. Water in the Hull after ride??? orange stain on ground after flush???
    By GTI-SE4426 in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 09-07-2008, 12:02 PM
  3. New 07 FX HO - After ride cleaning
    By bldguy65 in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 08-16-2008, 09:57 AM
  4. After Riding Maintenence
    By bassdocktor in forum Yamaha Open Discussion
    Replies: 8
    Last Post: 07-08-2008, 11:30 PM
  5. Need Exhaust parts for 98 GP-760 PLEASE"
    By gutterboy2ca in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-09-2008, 05:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •