Results 1 to 3 of 3
  1. #1
    Spike's Avatar
    Join Date
    Oct 2006
    Location
    Delaware
    Posts
    314
    +1
    1

    Low voltage to bilge pump 04 XPDI

    Hi All, I'm hoping to get some help here.

    Checking the electric supply to the bilge pump I found 4.5 V when the lanyard is unplugged, about 6V when the lanyard is plugged in and only about 7V with the engine running.

    I don't know where to look next for bad connections or is there some electronic switch just for the bilge? If anyone has any experience or knowledge of this please help.


  2. #2
    PEST!'s Avatar
    Join Date
    Jun 2008
    Location
    Rockledge Florida
    Posts
    768
    Check the ground side and if its good then replace the fuses in the mpem (seen a couple that were half blown. Threw me too) Clean the pins in the connector at the mpem. Your MPEM could be the problem. But I will bet the ground is bad or the pins loose
    Hey Guy you still Jumpin I see.

  3. #3
    Spike's Avatar
    Join Date
    Oct 2006
    Location
    Delaware
    Posts
    314
    +1
    1
    Thanks Pest,

    I think I found the connections at the mpm, having a little trouble distinguishing the tracer color on the red wire. With the mpm and bilge pump connection unplugged I get 1.7 to 2.0 ohms through the wires. After re-connecting the mpm I get more voltage 8-10 but still not enough so I think the wire to pin connection may be bad. Is there a special tool to remove the pins from the mpm plug? How do I get them out of the plug?


    I live for the waves and this weekend should be huge up here I gotta get this fixed asap

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. HOW TO: Bilge Pump, Groco Strainer & 4" Kanaflex Install
    By jpt7779 in forum Sea Doo How To & FAQs
    Replies: 203
    Last Post: 05-23-2016, 06:24 AM
  2. How-To: Bilge Pump Installation in an RXP-X (Lots of Photos)
    By RobWCanada in forum Sea Doo How To & FAQs
    Replies: 46
    Last Post: 08-11-2013, 07:37 AM
  3. How-To: Bilge pumps
    By USS RXT in forum Sea Doo How To & FAQs
    Replies: 59
    Last Post: 03-16-2010, 10:02 PM
  4. Replies: 9
    Last Post: 05-03-2009, 10:11 PM
  5. Access to bilge pump????
    By meangreen in forum Kawasaki PWC Performance (4-stroke)
    Replies: 31
    Last Post: 10-16-2008, 01:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •