Results 1 to 9 of 9
  1. #1

    Jet Pump won't come off

    I have a 1994 Seadoo XP.
    The impeller spins freely from the shaft so I believe I the splines are stripped but I can't get the pump off to verify.

    I removed all the bolts that are necessary, but can not get the jetpump to budge.

    I tried everything including the jetpump reomval tool. I have soaked it with PB blaster, and tried tapping the bolts to loosen some of the corrosion (if that is the problem) and still nothing.

    I was going to remove the skid plate to try and get some leverage with a pry bar, but the skid plate has a couple of bolts that won't come out and I have not drilled them out yet.


  2. #2
    785xp's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Posts
    897
    +1
    7
    Did you disconnect the hoses on the inside of the hull?

  3. #3
    Quote Originally Posted by 785xp View Post
    Did you disconnect the hoses on the inside of the hull?
    Yes,
    The two bilge and the one water line.

    I did not disconnect the drive shaft. There is ZERO play in the jetpump. If it was the shaft or something else, I would think that there would be just a little play.

  4. #4
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    They are glued on there with "The Right Stuff" for the most part. The shaft could not hold it on unless it were locked into the prop and the PTO.

    They can be a real bear if they have never been off since they are glued onto the hull. A come-along anchored to a tree often works (with the trailer hooked to a car on the other end). I once saw a guy chain the pump to a tree and use his truck to pull the trailer forward and thus the pump off. We had tried everything else. This was also on a '94 XP, as I recall.

    Just make sure all the fasteners are off and then apply some extraordinary force.

  5. #5
    Quote Originally Posted by KrunchovXPL-GTX-RX View Post
    They are glued on there with "The Right Stuff" for the most part. The shaft could not hold it on unless it were locked into the prop and the PTO.

    They can be a real bear if they have never been off since they are glued onto the hull. A come-along anchored to a tree often works (with the trailer hooked to a car on the other end). I once saw a guy chain the pump to a tree and use his truck to pull the trailer forward and thus the pump off. We had tried everything else. This was also on a '94 XP, as I recall.

    Just make sure all the fasteners are off and then apply some extraordinary force.
    I did the chain and tree trick. NOTHING.
    I used a backhoe and a chain attached to the jetpump. The backhoe dragged my truck and ski backwards a couple of feet.

    The corrosion has it welded in there

  6. #6
    Spike's Avatar
    Join Date
    Oct 2006
    Location
    Delaware
    Posts
    314
    +1
    1
    Quote Originally Posted by njcowboy View Post
    I did the chain and tree trick. NOTHING.
    I used a backhoe and a chain attached to the jetpump. The backhoe dragged my truck and ski backwards a couple of feet.

    The corrosion has it welded in there
    Can you post a picture of this? Maybe someone can see something missed??

  7. #7
    KrunchovXPL-GTX-RX's Avatar
    Join Date
    Mar 2009
    Location
    Aiken, SC
    Posts
    1,391
    +1
    1
    Quote Originally Posted by njcowboy View Post
    I did the chain and tree trick. NOTHING.
    I used a backhoe and a chain attached to the jetpump. The backhoe dragged my truck and ski backwards a couple of feet.

    The corrosion has it welded in there
    Wow.

    Chain it to a tree and pull it with the backhoe.

  8. #8
    Quote Originally Posted by KrunchovXPL-GTX-RX View Post
    Wow.

    Chain it to a tree and pull it with the backhoe.
    I finally got it out.
    Pulled one stud in the process.

    It had the original wear ring and neoprene seal on it. Sad thing is that the wear ring is still within compliance. The ski never got used.

    Now I am off to find a new shaft and impeller.

  9. #9

    Join Date
    Dec 2006
    Location
    Tacoma
    Posts
    29
    i have prop and shaft $85 shipped

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pump won't come off!
    By andrew1289 in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 09-22-2014, 01:26 PM
  2. Pump won't come off
    By OneJESUSGod in forum Sea Doo Build Threads
    Replies: 3
    Last Post: 08-26-2012, 12:48 PM
  3. 96xp won't come off idle easy
    By chrislaw in forum 2-Stroke Performance
    Replies: 8
    Last Post: 07-08-2009, 11:00 AM
  4. %&$#$%$#$ Ultra 130 pump won't come off
    By nmpeter in forum Kawasaki PWC Performance (2-stroke)
    Replies: 8
    Last Post: 06-11-2009, 06:49 PM
  5. jet pump won't pull out
    By COUJAR in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 05-08-2008, 10:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •