Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20

Thread: Running Rich

  1. #1

    Running Rich

    I have a 1994 sl750 and i noticed that when i just go slow around 2000-2500 rpm not on plane i can really see the blue smoke from the oil. But once i get it wot you dont see/smell the smoke anymore. Also when i first take the ski out it smokes alot then clears up. Also i been noticing that when i first take the ski out it will hesitate for a while and not allow me to go full throttle until it warms up. I think it is running to rich. I switch oil a while ago from amsoil to pennzoil synthetic, I like amsoil better but i dont think switching oil is causing this bc i still remember it smoking with the amsoil. Anyone have any ideas thanks


  2. #2
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    is it still oil injected? If so, you will get more oil at idle than will at speed. So thats the way it is

  3. #3
    Yes it is still oil injected. But when i look at other skis that are oil injected they dont smoke as much. What can be causing the hesitation. Thanks

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by jbwoodshop19509 View Post
    Yes it is still oil injected.

    But when i look at other skis that are oil injected they dont smoke as much...
    Have you checked that the variable rate linkage to the oil pump from the carbs is actually connected and working?

    I think 1994 was the first year for the variable rate oil pumps. I didn't actually check that, however

    Have the carbs been cleaned/rebuilt in recent times?

  5. #5
    I am not sure if it is a varable rate oil pump how can i check.. I know the guy i bought the ski from did a lot of work on it and i think he did. But you cant go by that. If it was putting out more oil than it needed could that cause the hesitation or would fuel just cause that. Thanks

  6. #6
    la90043's Avatar
    Join Date
    Oct 2006
    Location
    Los Angeles
    Posts
    1,201
    the smoke you'll never get rid of unless your running/riding the ski. At idle you'll have some smoke. And smoke more the more you idle. Thats a 2 stroke. As for the hesitation check your low speed adjusting screws. Check and see if they're at factory stock setting.

    Does it bog a little.

    Or it doesnt bog but just hesitates a little to get up to speed?

  7. #7
    When i first start the ski up it will take a while before i can go wot. My max will be like 4500-5000 for about 2 min or less until it warms up then it is fine. But it does just go from 5000-6000 you can hear the engine hesitating a bit and gradually increasing the rpms.

  8. #8
    Also if i just idle for a while and then go right to wot it hesitates just for a sec then is fine

  9. #9
    la90043's Avatar
    Join Date
    Oct 2006
    Location
    Los Angeles
    Posts
    1,201
    have you checked for correct carburetor settings for the low speed and high speed adjusters on the carburetors huh?

    What have you done to remedy the problem huh?

  10. #10
    No I have not checked. I know the guy i bought it from rebuilt it 3 times. Can i find the settings in the service manual.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 slt 750 runs rich, boggs
    By brianstrange in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-10-2008, 10:04 AM
  2. 05 scic running rich
    By Giligan in forum Sea Doo Sport Boats
    Replies: 4
    Last Post: 07-01-2008, 09:53 PM
  3. Polaris SL650 Fuel Mixture (running Rich)
    By danwann in forum Polaris Open Discussion
    Replies: 9
    Last Post: 06-16-2008, 06:50 PM
  4. Polaris SL650 Fuel Mixture (running Rich)
    By danwann in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 06-02-2008, 08:52 AM
  5. running rich?
    By shhr in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-02-2007, 10:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •