Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    SS wear ring installed but IMPELLER touches side

    I have an 03 GTX 185hp and I last night installed a new SS wear ring and new solas impeller from the riva stage I kit. After installing impeller and wear ring together you could turn the impeller about 3/4's of the way and it would touch the side of the new ss ring. How is this possible?


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    It's a super tight fit. The tighter the better!

  3. #3
    2006 Turbo RXP boBO's Avatar
    Join Date
    Mar 2008
    Location
    STATE OF KUWAIT
    Posts
    1,034
    Quote Originally Posted by Green Hulk View Post
    It's a super tight fit. The tighter the better!
    Indeed

  4. #4
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,759
    +1
    29
    I had to take a lil off my wheel.

  5. #5

    Join Date
    Aug 2009
    Location
    La Porte Tx
    Posts
    189
    Quote Originally Posted by 03mustardrockets View Post
    I have an 03 GTX 185hp and I last night installed a new SS wear ring and new solas impeller from the riva stage I kit. After installing impeller and wear ring together you could turn the impeller about 3/4's of the way and it would touch the side of the new ss ring. How is this possible?

    Sounds like both the wear ring and impeller are not perfectly round if it only hits in certain places.

  6. #6

    Join Date
    Feb 2008
    Location
    novwhere
    Posts
    597
    Quote Originally Posted by Green Hulk View Post
    It's a super tight fit. The tighter the better!
    Yes TIGHTER better but not in ski .....

  7. #7

    Join Date
    Aug 2009
    Location
    La Porte Tx
    Posts
    189
    Or maybe the wear ring is not centered to the impeller and the impeller is not perfectly round. Is this a common problem with the ss wear ring?

  8. #8

    Join Date
    Feb 2008
    Location
    novwhere
    Posts
    597
    Quote Originally Posted by Ken IS255 View Post
    Or maybe the wear ring is not centered to the impeller and the impeller is not perfectly round. Is this a common problem with the ss wear ring?
    I have also SS rings in my pumps, and also too tight. I mod bit my impellers, but really bit.

  9. #9
    homebrew's Avatar
    Join Date
    Aug 2008
    Location
    Hampton Va.
    Posts
    556
    now if i can only convince the women tighter is better !

  10. #10
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    Quote Originally Posted by 03mustardrockets View Post
    I have an 03 GTX 185hp and I last night installed a new SS wear ring and new solas impeller from the riva stage I kit. After installing impeller and wear ring together you could turn the impeller about 3/4's of the way and it would touch the side of the new ss ring. How is this possible?
    What pump do you have? If its the plastic one then it sounds like it warped to me.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SS wear ring install problems
    By aha in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-08-2008, 08:27 PM
  2. New impeller rubbing on new ss wear ring...
    By Alaska05RXT in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-16-2007, 02:27 AM
  3. New Impeller & Ss Wear Ring
    By LAB69 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 03-06-2007, 04:25 PM
  4. Install on SS Wear Ring
    By sr71bb in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-23-2006, 05:27 PM
  5. Installing SS wear ring?
    By Yuji in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-16-2006, 10:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •