Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Jul 2009
    Location
    st john in
    Posts
    146
    +1
    4

    o5 gtx sc rebuild

    i just had my sc completly rebuilt. had a 107 hours on it. stage 1 on it. was getting 7500rpm now getting 7400rpm. dealer says they didn't do any thing wrong. both tests were done in same conditions. what could be the problem with sc? i'm sure i'll be taking the sc out. thanks!


  2. #2
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    what mods did you put on exactly??
    it could be that your impeller is pitched too steep??
    however, when is the last time you saw 8000-8100 rpm??
    when your SC went out, did you lose the oem ceramic clutches?? and was teh engine properly cleaned if you did??
    simple test right now is to remove the intake hose from the SC, with ski off.
    stick fingers in and try to spin the SC fanblade. it should not move

  3. #3
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    Quote Originally Posted by mr. t View Post
    i just had my sc completly rebuilt. had a 107 hours on it. stage 1 on it. was getting 7500rpm now getting 7400rpm. dealer says they didn't do any thing wrong. both tests were done in same conditions. what could be the problem with sc? i'm sure i'll be taking the sc out. thanks!
    I have a 05 GTX-SC (185hp) also, had Jerry do SC rebuild at 104 hours. The limiter is 7650 not 8100!!!!!!!!

    If the temp (air and water) has gone up alot since you last ran it is probably normal. Are you running stock impeller pitch? The water and air temps make a huge impact on performance. I suspect nothing is wrong.

    see my signature for a comparison.

  4. #4
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    The dealers said that they didn't do anything wrong, but did they do anything right? That's why many people send their SCs to Jerry so they know it's done right... Ron

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    I doubt anything they did caused a 100 RPM loss from one day to the next.

    Barometric changes/density altitude changes, etc. can easily cause 100 rpm difference from one day to the next.

    worn wear ring can cause lower RPM's

    Over filled oil can also cause lower RPM. Was an oil change done at the same time?

    If the dealer did something wrong the supercharger would get 6400 RPM and not just bee down 100 RPM.

  6. #6

    Join Date
    Jul 2009
    Location
    st john in
    Posts
    146
    +1
    4
    i ran in identical conditions. i have riva's stage 1 on it. i went from 7600 to 7500rpm after the stage 1. riva said rebuild the sc to get it back to 7600. well i finaly did and now i'm getting 7400 and lost atleast 1mph. you think i would have gained something, not lost!

  7. #7
    who rebuilt the SC? the dealer? sadly most are not qualified to do so...
    maybe the slip moment is not correct and most likely the stage one prop is to tall. if you have a 12\20 prop on there, it needs to be repitched to get that couple of rpm`s back...

    what is the air temp where you ride currently?

  8. #8

    Join Date
    Jul 2005
    Location
    Lake Dunlap, Texas
    Posts
    1,600
    +1
    28
    The non-intercooled 185 HP is much more senestive to temp changes and heat soak. It can vary several 100 RPM on the same pull. I would not worry about 100 RPM gain or loss with this set up, especially in the sumertime. Where are you located?

  9. #9

    Join Date
    Jul 2009
    Location
    st john in
    Posts
    146
    +1
    4
    it was 75 degrees for both runs, it might of even been cooler when i got the 7400. when it gets close to 90 i'll get about 7250 to 7300. i was getting 68 on the speedo now 66.closest i had to gps, i ran along side someone at 66 he had me at 64. my solas is 13/20r. how do you adjust the slip moment?
    Last edited by mr. t; 08-23-2009 at 08:22 PM.

  10. #10

    Join Date
    Jul 2005
    Location
    Lake Dunlap, Texas
    Posts
    1,600
    +1
    28
    Again--Where are you located??

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 GTX SC Rebuild Question
    By freddypagaga in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-08-2010, 05:52 PM
  2. 04 GTX sc hesitation...just had jerry rebuild sc?
    By jwyrick in forum 4-Tec Performance
    Replies: 14
    Last Post: 06-11-2009, 03:46 PM
  3. 03 Seadoo GTX SC Rebuild?
    By iolaus in forum 4-Tec Performance
    Replies: 19
    Last Post: 07-17-2008, 08:47 AM
  4. 2003 GTX SC Rebuild Help Please!?
    By GTXDawg in forum 4-Tec Performance
    Replies: 42
    Last Post: 05-27-2008, 04:48 PM
  5. 03 gtx sc scharger rebuild
    By green_head in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-12-2006, 07:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •