Results 1 to 4 of 4
  1. #1

    Help 99 Gsx Runs Then Dies

    just rebuilt my 99 gsx its a 2mm over bore raves have been shaved to spec all fuels lines have been replaced carbs cleaned rebuilt all filters chnaged with the process...the ski runs great on the hose no issues what so ever...when i put it in the water it will start up run till you about on plane and die out...it still beeps and the guages display but no message or code or error.it seems like the ignition is cutting out because the plugs are wet .it seems like some1 is pressing the stop button but im lost here any help guys thanks


  2. #2
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    You may just have a bad lanyard post. I've seen batteries do this too in GSX's, but they normally don't restart. If you have an extra battery swap it, then check all your grounds, especially the ground post in the bottom of the rear black box. Then check the pins in the top plug of the same box. If all check ok, then try the lanyard post.

  3. #3
    will check 2morrow thanks

  4. #4
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Check your front plug on the engine too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help- 99 GSX RFI died and won't restart.
    By kwiktsi in forum 2-Stroke Performance
    Replies: 5
    Last Post: 11-14-2012, 10:33 AM
  2. Please help....97 pro 785 runs then dies
    By billybobtucson in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 07-30-2009, 12:48 AM
  3. 97 gsx runs then dies
    By canoelicker in forum 2-Stroke Performance
    Replies: 3
    Last Post: 06-21-2009, 08:20 AM
  4. runs then dies
    By rxpiowa in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-04-2008, 11:22 AM
  5. SL650 Runs then dies
    By Scoundralzzz in forum Polaris Open Discussion
    Replies: 23
    Last Post: 06-27-2008, 12:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •