Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    CHAD IBADTON's Avatar
    Join Date
    Jul 2008
    Location
    on lake Harding AL
    Posts
    558
    +1
    34

    Antifreeze coming out of overflow and idle rough

    My ski has been idling rough and hard two crank sometimes. 20 hrs on plugs so I put new in cleared up rode for 1 hr took seat off smelled antifreeze. seems two becoming from my overflow tube cap and spring are good. so im thanking HEADGASKET oil is the same level and ski runs great ran 81.3 at 8350 13.6 boost 12.1 af. ski is a stage 3+rude2 thanks for any help or opinions?


  2. #2
    Poppa Dawg's Avatar
    Join Date
    Dec 2005
    Location
    Alice. Texas
    Posts
    1,015
    +1
    49
    Quote Originally Posted by IBADTON View Post
    My ski has been idling rough and hard two crank sometimes. 20 hrs on plugs so I put new in cleared up rode for 1 hr took seat off smelled antifreeze. seems two becoming from my overflow tube cap and spring are good. so im thanking HEADGASKET oil is the same level and ski runs great ran 81.3 at 8350 13.6 boost 12.1 af. ski is a stage 3+rude2 thanks for any help or opinions?
    After everyone comes on here & tells you its your head gasket, & after you change your head gasket, & after you make sure your oil cooler lines are not reversed, & after you change your head gasket again & mill your head & then you are still puking fluid, go ahead & put on an open loop system & your problem will go away. I'm guessing your air temps are close to 100* & water temps are in the 90's*. Just my .02. I'll fade into the background now. Good luck.

    Doug

  3. #3
    Quote Originally Posted by Poppa Dawg View Post
    After everyone comes on here & tells you its your head gasket, & after you change your head gasket, & after you make sure your oil cooler lines are not reversed, & after you change your head gasket again & mill your head & then you are still puking fluid, go ahead & put on an open loop system & your problem will go away. I'm guessing your air temps are close to 100* & water temps are in the 90's*. Just my .02. I'll fade into the background now. Good luck.

    Doug
    I'm running close loop on a boat why past stage 3 and have no problems.I have milled head,porting,cam and a ET charger at 16psi.I've ran 90 water and 96 air with no overheating or loss of water.Open loop will just mask the problem till it's to late.The boat is capable of running 90mph but I'm set up for racing close course 84mph.

  4. #4
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Rough idle? Whats your AF at idle? Puking coolant. More than likely a headgasket. I am still running close-loop at about 8700rpm without issues after doing a headgasket, studs, cutting the head, 158* thermostat. I don't race my ski maybe the difference between Dawg amd my results. But Mitch does race his ski.

  5. #5
    Poppa Dawg's Avatar
    Join Date
    Dec 2005
    Location
    Alice. Texas
    Posts
    1,015
    +1
    49
    Quote Originally Posted by mitch411RXP View Post
    I'm running close loop on a boat why past stage 3 and have no problems.I have milled head,porting,cam and a ET charger at 16psi.I've ran 90 water and 96 air with no overheating or loss of water.Open loop will just mask the problem till it's to late.The boat is capable of running 90mph but I'm set up for racing close course 84mph.
    This is exactly what I was talking about. You can do a search about this topic and find all sorts of people with different stages of modifications & some will have no problems & others will continue to have problems. For whatever reason, it appears that some of these motors create excessive heat when we start adding power to them & it appears that the problem is compounded somewhat by climatic location.

    Kawasaki & Yamaha have used open loop for years with no problems. Once you have established the fact that a problem has not been created by loosing your fluid ( warped head ) you may find it beneficial to go to an open loop system.

    In Mitch's case, his boat has not been affected & that is just wonderful. There are many on this forum who have changed head gaskets, milled, changed heads .... & the problem persisted until they went to a different cooling set-up.

    Jerry Gaddis ( The Man! ) himself just addressed this exact problem in the thread about open loop a couple of days ago. Some boats will continue to have a problem.

    If there is a problem, fix it. Then go open loop. If you continue to chase your tail, try going open loop. I'm just trying to help here so lets not throw anyone under the bus.

    By the way, I also have a Stage 3 race boat with lots of little goodies. At stage 1 1/2 I started puking fluid. After changing head gaskets numerous times, milling the head, changing the head & pulling my hair out, I went open loop , put a temp. gauge on, & have been rolling ever since without any cooling problems.

    The person who stated this thread needs to PM or e-mail Jerry & get his take on it.

    Doug

  6. #6
    Gus13letter's Avatar
    Join Date
    Apr 2008
    Location
    Tampa Bay, FL
    Posts
    8,136
    +1
    822
    Maybe a bad thermostat?
    Did it just happen or did you have anything apart before this happened?

  7. #7
    Poppa Dawg,I had the same thing your talking about.I milled the head 2 times and still leaked.When we did the block it was out too and my fix was "O" ring the block.I've put 25 hrs on mine sense and all is good.I will tear it down at the end of the season to do more to it.I hope it makes it that long.

  8. #8
    Poppa Dawg's Avatar
    Join Date
    Dec 2005
    Location
    Alice. Texas
    Posts
    1,015
    +1
    49
    Good Luck Mitch. Your boat sounds like its rockin. We'll be pulling for you. You doing both nationals & World's?

    Doug

  9. #9
    Quote Originally Posted by Poppa Dawg View Post
    Good Luck Mitch. Your boat sounds like its rockin. We'll be pulling for you. You doing both nationals & World's?

    Doug

    Nationals for sure and if the sponsor comes through WF.You going to be at either one?Thanks Mitch

  10. #10
    CHAD IBADTON's Avatar
    Join Date
    Jul 2008
    Location
    on lake Harding AL
    Posts
    558
    +1
    34
    Other than a tdr water box nothing has changed stage 3 for 40 hrs but I have stock thermostat. Waiting 2 figure this out before doing the jd1 open loop and where are u putting the sensor for water temp at?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GP1200R - Coming out of sabatical - hints and tips?
    By Vifferrider in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 02-23-2015, 03:25 PM
  2. Replies: 5
    Last Post: 07-04-2009, 02:08 AM
  3. how do i get smell out of gloves and shoes?
    By cue03 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 04-24-2007, 08:47 PM
  4. Yawn... Time to come out of Hibernation...
    By majundecid in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 04-02-2007, 04:47 PM
  5. Oil coming out of SC
    By lafjax in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-12-2006, 12:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •