Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1

    MSX 150 no start after head gasket.

    Hey folks, looking for some serious insite. I bought an MSX 150 (I'm begining to think this was my first mistake). Bought it knowing it overheated, seller figured it needed a water pump. After some testing, I determined the head gasket had failed. Out came the engine, new head gasket. Back it. (What a miserable job that is). Now everything back in and I can get it started. Turns over great. Replaced the battery regardless. When lanyard first installed nothing happens. If I touch the start button I get the usual clicking from the main power relays. Have fuel pressure right on spec. NO SPARK OR FUEL INJECTOR FIRING THOUGH. The multifunction display DOES NOT power up when turned over, have to press the mode button to get it to power up. When the display is powered up and I crank it it only sometimes shows RPM, not sure if this is normal as I just got the machine. Checked the Engine position sensor resistance is ok and viewing on an occiliscope shows a constant pattern with 1 blip/extra space for TDC with a peak of approx 3 volt. Checked the cam sensor for 5v and gnd - ok, tried the occiliscope on the cam sensor sensor to ground but just get a contstant 5V, but don't know what I should see on a three wire/active sensor. Have tried to bypass the main power relays. checked all sensors for being plugged in (checked off one by one using wring diagram). Have the factory manual (kind of a joke, except for engine R and I and dis/reassembly). Thanks for any help.

  2. #2
    Kosh's Avatar
    Join Date
    Sep 2007
    Hi jewraffe,

    You did not make a mistake, you will love it once you get it running. This has happened to me in the past and it come down to the battery unable to keep up its end of the deal.

    To quote the manual-
    Static battery voltage must be at least 12Vdc.
    Voltage drop cannot drop below 10.5 Vdc
    while pushing START button.

    This may not be your problem but it has caught a few of us out a some stage.


  3. #3
    I have done quite a few of these and agree it is a great job Try puliing three engines in less than a month over bad turbo's ..
    Anyway, I had this problem on one of mine, was a ground. Did the engine run ok before you removed the engine? Kinda curious how you replaced the head gasket without pulling the lower end (timing reasons).. Never the less, Where are you located? Sounds like the ecm isnt seeing engine position, but you said it wont turn over sometimes??

  4. #4
    Thanks for the replies. As I realized from previous research on here I installed a new batt as well as have connected a booster battery. Cranking voltage at battery side of solenoid holds at 11.3 volts while cranking. Spark plugs in.

    I indeed did have the bottom of the engine apart due to timing marks and tensioner. I did'nt have the tool to pull the timing wheel/balancer so I made my timing marks prior to diassembling. Fairly confident my cam timing is correct and that shouldn't diable the ignition/injectors regarless unless the ECU shuts everything down if it sees a major variance in the engine position sensor and the phase sensor but can't see that. So if cam is out should get piston to valve contact at the worst or at least some backfiring or similar.

    Just borrowed the laptop from a buddy at the local polaris dealership, but they are not PWC (can't even get parts for them) so have to adapt some cables to connect, hopefully. Will let you know.

    Oh yeah, I am in southern Alberta, Canada.

  5. #5
    Too far for me to drive and help.. lol.. Did it run before you tore it down?

  6. #6
    Yep, it ran before I screwed it up. Some more points to add, can not get Digital Wrench to connect to the ECU, which tells me ECU is not powering up. Also if I wake up the display and crank the engine it does not display any RPM. And if I install the lanyard I do not have control of the electronic throttle (if I am reading the manual correctly I should with the lanyard on).

  7. #7
    Can't say for sure yet, had to quit for the night or get divorced, but I began testing individual wires at the ecu. Tested the ground wire at ECU300, pin H4. The resistance check to ground was perfect (0 ohms), however a voltage check accross H4 and batt positive only gave 1.3 volts. Wiring diagram shows this as being the "ignition ground" but after 9 (yes 9) splices it is the large ground wire to the block. I couldn't remember where this connected when I put the motor back it so I put it and the main gnd cable from the batt on the stud at the back of the intake manifold, couldn't find any other reason for the stud so made sense to me. I will pull the cables off tommorrow and clen them and the manifold up. The manifold is brand new (original was cracked and welder made a mess of it, so ended up buying new), and forgot to clean off the powder coat/paint when I swapped the studs. Will let you know how it goes tommorrow or Sunday.

  8. #8
    Dont forget about the few grounds that are toward the lower part of the engine kinda to the right of the oil tank if you were standing at the rear of the ski.

  9. #9
    Success, sort of. Got her running. As I hang my head in shame and get my ego knocked down a few notches, I left a ground wire off. After some of the comments here and I calmed down and started thinking about it logically, I re-studied the wiring diagrams and found the engine harness and chassis harness both have ground wires to the block, here I connected the chassis ground thinking it was the one in the engine harness, so long story short, I screwed up.

    Now the next problem. Runs, but idles at about 3500 rpm, and if I even touch the throttle shoots straight to 8000 RPM and holds there until i shut it off. Performed the Electronic Thottle relearn proceedure as outlined in the manual, no change. I am lucky enough to have digital wrench up and connected to it and am getting 15-32 lbs boost at all times (or so it claims), running or not, and an intermittant overboost code. Pulled the boost sensor out while running, still claimed boost. Tested the boost sensor wiring, ok, so will order one on monday and give that a try. Have to return digital wrench to buddy first thing monday morn (before the boss gets to the shop Other than that it sounds alright, so must have the cam timing correct.

    Can anyone tell me why a boost sensor as well as a manifold pressure sensor. Kind of redundent I think, but if the boost sensor fails does the ECU read from the manifold pressure sensor instead. I disconnected the boost sensor while running and Digital wrench continued to show boost, so wondering if both sensors could be shot. Does not give an option to monitor manifold pressure.

  10. #10
    just looked at the parts breakdown, manifold pressure sensor and boost sensor are aven the same part number. ECU must just ignore the temp side of the manifold pressure sensor.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. msx 150 limp mode after 1/2 throttle
    By highvoltage21733 in forum MSX/Matrix
    Replies: 14
    Last Post: 12-11-2013, 09:03 PM
  2. MSX 150 Wont start in water
    By Jpac in forum MSX/Matrix
    Replies: 9
    Last Post: 02-11-2013, 07:27 PM
  3. Replies: 5
    Last Post: 08-05-2011, 07:50 PM
  4. msx 150 hard starting only sometimes!?!?!
    By Hinchi in forum MSX/Matrix
    Replies: 1
    Last Post: 01-08-2011, 02:45 PM
  5. MSX 150 won't start back up
    By Todd in forum Polaris Open Discussion
    Replies: 20
    Last Post: 04-28-2007, 07:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts