Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    Riding Dirty GP1300R's Avatar
    Join Date
    Dec 2007
    Location
    Connecticut
    Posts
    496

    2009 RXT-X Antifreeze leak(looks like rideplate)

    Hey guys, I have an '09 RXT-X I picked up a little over a month ago. Yesterday we were out and riding pretty hard. I noticed this morning I have an antifreeze leak. It is coming from the back and as far I know(could be wrong) the rideplate is the only thing that can cause this. I gave it a quick glance and see no visible cracks. A few small scuffs but I am sure that is just from the beach, not any impact.
    Is this common>??? Is it something I should just take care of myself or should I bring it to the dealer as a warranty claim>???
    Any thoughts, opinions or advice is greatly appreciated! Thanks, Mat


  2. #2
    ctriverguy's Avatar
    Join Date
    Aug 2007
    Location
    Ipswich, Massachusetts, United States
    Posts
    1,509
    +1
    8
    check the top side of the plate in by the pump


    the screws in there weep on mine... kind of a common thing i guess

  3. #3
    Riding Dirty GP1300R's Avatar
    Join Date
    Dec 2007
    Location
    Connecticut
    Posts
    496
    Quote Originally Posted by ctriverguy View Post
    check the top side of the plate in by the pump


    the screws in there weep on mine... kind of a common thing i guess
    It is more than a small weep. It is leaving spots on the ground.

  4. #4
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by GP1300R View Post
    It is more than a small weep. It is leaving spots on the ground.
    Take to the dealer if under warranty. Or drain coolant and take as many screws as you can one at a time and put Ultra Black on them and tighten back up.

  5. #5
    Riding Dirty GP1300R's Avatar
    Join Date
    Dec 2007
    Location
    Connecticut
    Posts
    496
    After looking at it some more it looks like the rear drain plug is leaking. I am guessing it is a drain plug at least. It is the rear most allen screw and runs parallel with the bottom of the ski.

  6. #6
    Riding Dirty GP1300R's Avatar
    Join Date
    Dec 2007
    Location
    Connecticut
    Posts
    496
    Quote Originally Posted by jp1300r View Post
    Take to the dealer if under warranty. Or drain coolant and take as many screws as you can one at a time and put Ultra Black on them and tighten back up.
    It's not the drainplug. Which bolts are we talking about>??? The ones at the top near the pump>???

  7. #7
    baba850r's Avatar
    Join Date
    Sep 2007
    Location
    scotland
    Posts
    673
    +1
    4
    my mates rxp-x has sae problem.he thinks its the black seals just under the pump.....what are they for?any way we can take these out with plate still on ski and reseal?

  8. #8
    baba850r's Avatar
    Join Date
    Sep 2007
    Location
    scotland
    Posts
    673
    +1
    4
    Quote Originally Posted by GP1300R View Post
    It's not the drainplug. Which bolts are we talking about>??? The ones at the top near the pump>???

    yes mate i think hes talking about the screws on the top of plate like below the pump.i had an rxp that had a small leak it turned out 4 torx needed tightened sum more.

  9. #9
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    You need to pull the pump and do has many as you can. Its not real hard to do.

    What seals just under the pump? There is one seal between the rideplate and the pumpshoe. Its not sealing coolant in. If you try and rip that seal out the ski more than likely start cavitating. Just check the screws on top of the rideplate.

  10. #10
    I have always found that removing the ride plate is the only way. If you leave it up and remove the pump you still can't get at all the screws. reseal the screws with "RIGHT STUFF" by permatex, as that is just about the only thing impervious to anti-freeze. let it dry and pressure check it to 15 pounds before installing.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2009 RXT-X 255hp Intercooler leak???
    By tricountytrail in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-14-2013, 08:36 PM
  2. Looks Like #3 Leaked coolant
    By sea-one in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-27-2013, 03:29 PM
  3. looking at 2009 rxt 215
    By deepinjersey in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 04-10-2013, 10:27 AM
  4. 1995 xp800 water leaking in, looks like from under engine?
    By demian5 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-09-2012, 01:07 PM
  5. well...looks like there is a leak
    By Kcauley in forum Yamaha PWC Performance (2-stroke)
    Replies: 18
    Last Post: 05-15-2009, 03:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •