Results 1 to 3 of 3
  1. #1
    fordpower's Avatar
    Join Date
    Jul 2009
    Location
    De Pere,wi
    Posts
    206

    96 sl900 no power

    i have a 96 sl900 that i got for a project and the electrical box was all corroded, so i replaced the circuit/fuse board and still no power to anything. any ideas???? I know the motor turns over since i jumped the solinoid and check compression. any help would be great.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Follow the Red/Purple wires back to the start solenoid.

    The Reset circuit breaker should connect to the same terminal on the start solenoid that also connects directly to the battery heavy cable.

  3. #3
    fordpower's Avatar
    Join Date
    Jul 2009
    Location
    De Pere,wi
    Posts
    206
    i'll check that. ive been trying to fine a manual for it but havent' had any luck, anyone know where to find one for my ski?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 900sl No power! wont start. help!
    By aydeayem in forum Polaris Projects
    Replies: 1
    Last Post: 12-06-2013, 10:15 AM
  2. 96 SL900 No Spark Blues
    By stour in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-17-2012, 04:00 PM
  3. 96. Waveventure - no power
    By Jasonrobbins in forum Yamaha Old School Skis
    Replies: 16
    Last Post: 11-08-2011, 08:21 AM
  4. 96 SL900 no spark
    By h400exrydr84 in forum Polaris PWC Performance
    Replies: 7
    Last Post: 07-20-2011, 07:24 AM
  5. 96 sl900 no spark (what else?)
    By azcornman in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-12-2007, 03:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •