Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    I have to handed to Richard (Way2fast)!!!

    Richard was dead on with the reccommendation of the Groco WSB-750 strainer. I can`t believe just how much debris this strainer captures!!!

    Kudos to you Richard for the wise tip!!!


    And to think it took less than 10 hours to plug up the Riva IC enough to cause a high temp alarm

    Anyone running a IC should install a strainer...PR...


  2. #2
    Connecticut CrazyA's Avatar
    Join Date
    Nov 2005
    Location
    CT.
    Posts
    8,134
    +1
    1,050
    Quote Originally Posted by Pale Rider
    Anyone running a IC should install a strainer...PR...
    Yup...

  3. #3
    Do you have the water way going the opposite of groco or following the arrows ?

  4. #4
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,181
    +1
    98
    Yes, run the water the opposite to the way it labeled so the debris is on the outside of the filter.
    I've run them for years on my Ultra 150 and they do the job. Just clean it before each ride.
    ** never let antifreeze touch it, the plastic will cloud and crack.

  5. #5
    Quote Originally Posted by Kinchyle
    Do you have the water way going the opposite of groco or following the arrows ?
    Kinch, I don`t have it that way. To me it doesn`t matter, bc I could still see debris in the strainer. It gets dark.

    Check this out: remember when I got all that eel grass in the IC, and I thought i got most of it out.
    Well after I drain the strainer of the debris, I screw it back on and reverse flush by holding the garden attachment (short rubber hose I have adapted to the garden hose) hose on the water exit of the IC, and you can still see and catch little bits and pieces of eel grass in the strainer. So little by little it is breaking down small enough to come out!...PR...

  6. #6
    Gforce's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    405
    A strainer is essential when putting in the RIVA IC. Unless of course you do all your riding in the local pool.

    I was clogging in less than 10 hours and all the flushing caused my IC to burst. Luckily RIVA is replacing it and I have a strainer in the line to prevent ever having to flush grass out of it again.....

  7. #7
    Quote Originally Posted by Gforce
    all the flushing caused my IC to burst. .....
    How did this happen???...PR...

  8. #8
    way2fast's Avatar
    Join Date
    May 2005
    Location
    Melbourne Beach, FL
    Posts
    4,009
    +1
    4
    Glad I was of help Andy !
    Back when I was actively selling the intercoolers, I strongly recommended installing the Groco strainer to prevent clogging. Not too many seemed to take my advice. Guys spend big bucks to make their skis go faster and then loose a lot of the "paid for" performance by having their coolers clog up, reducing efficency....all because they don't use a strainer.

    Richard

  9. #9
    Quote Originally Posted by way2fast
    Glad I was of help Andy !
    Back when I was actively selling the intercoolers, I strongly recommended installing the Groco strainer to prevent clogging. Not too many seemed to take my advice. Guys spend big bucks to make their skis go faster and then loose a lot of the "paid for" performance by having their coolers clog up, reducing efficency....all because they don't use a strainer.

    Richard

    Believe me! I learned my lesson. That became another expensive weekend, replacing riva pipe with rotax retro-fit pipe, getting replacement IC tubes, engineering the seperate IC cooling system/with gauge and incorporating the Groco strainer into it! It never ends! ...PR...

  10. #10
    Gforce's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    405
    Quote Originally Posted by Pale Rider
    How did this happen???...PR...
    I used everything to clean it including some aluminum cleaner that was a little acidic. I think the acid weakened the wall of the IC and caused to to burst when it saw the pressure of the pump. I really wish I had known the severity of the clogging issue. I literally tried everything I could think of to get it clean before the aluminum cleaner flush. Nothing would make it flow better.

    Looking back I think I had a leak problem to begin with as even before it was clogged my ski was bogging off the line after a long Idle. I have a 10-15 min slow ride up the river from my house to get out to the fast stuff and always the ski would bog at first due to the IC filling with a slow leak and then clearing out when I got on the boost. Then at high speeds the leak was overcome by the air and only affected a little bit. Finally it got bad enough that it choked out the motor and I had to have the IC replaced. I had no idea what it was at first. Now I know what a leaking IC feels like even if it's a slow leak.

    With the IC before all the clogging and known leaking issues I was only turning around 7700 RPM sometimes less. I attributed it to heat fade and was never the wiser. Now that I am running with no IC at all I am seeing 7900.

    Basically it's been a long painstaking lesson but now I know what went wrong and how to prevent and diagnose it in the future.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Sorry I HAVE TO DO THIS...Where is everyone from????
    By two2curupt in forum Open Discussion
    Replies: 127
    Last Post: 02-21-2007, 11:40 PM
  2. Changing oil this weekend does it have to be for wet clutch
    By macattack in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-17-2005, 10:03 PM
  3. Instaling my BOV do I have to use the middle notch????
    By Jrsrxp in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-22-2005, 07:32 PM
  4. have to give it to greenhulk
    By rrrxxxppp in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-01-2005, 07:22 PM
  5. Got my IR Plugs for my RXP. Do I have to wait?
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-21-2005, 11:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •