Results 1 to 4 of 4
  1. #1

    starting problem

    i am trying to start my sl750 and all i get is a click. it is coming from in the electric box. maybe where the positive cable and starter meet at that soleniod.i am getting 12v from the battery. my trim works so i know its not all bad. any help or info would be great.

  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    Try doing a search for 750 won't start. It's been gone over a few times lately.

    It'll have all the things to look into.

  3. #3
    2001 virage tx bossdog67's Avatar
    Join Date
    Jul 2009
    saskatchewan , canada
    could be the starter solinoid . try jumping the solinoid with a screw driver . ( touch the 2 posts where positive from battery comes in ) if it starts , i am thinking no power is going thru and closing the connection on solinoid !! you don't even need to start , just try and turn it over this way !! this way you know it works from this point forward , and you can start working backwards to find your issue !!

  4. #4
    Yeah do a search, there are a few things that can go wrong. But if the motor isn't locked up, I'd say your starter is bad. They can get water in the bearings and the bearing gets rusty, goes bad and locks up. You can get a rebuild kit for them off fleabay.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 sea doo starting problems
    By tom in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-02-2006, 09:30 PM
  2. 1200xll starting problem
    By hammerdog57 in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 06-27-2006, 08:08 PM
  3. 05 RXP Starting problems
    By Cody Townsend in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 05-09-2006, 05:51 PM
  4. '01 Xlt 1200 Hot Start Problem
    By belgianhead in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-09-2006, 11:08 AM
  5. 04 RXP Starting problem/question...
    By BLOWNRXP in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-01-2005, 10:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts