Results 1 to 10 of 10

Thread: low idle?

  1. #1

    Talking low idle?

    whats up guys, just picked up a 2004 stx 12f for a friend new to the sport. the ski is mint engine is mint has 160hrs on it. i was testing the ski out today and noticed that the idle seems to low. the ski even shuts off some times when letting off the throttle even after warmed up. plugs have been changed "supposedly". can it just be that i have to raise the idle a tad? any info would be great guys thanks again


  2. #2
    2005 RXT Red08Ultra250's Avatar
    Join Date
    Feb 2008
    Location
    Dunedin, FL
    Posts
    908
    does it have fresh gas? are you shure the plugs are good? Raising the idle might only hide those symptoms.

  3. #3
    that's true i might change the plugs anyway. but the idle just seems way to low. thanks red

  4. #4
    any one else have any ideas? or has had this problem? thanks

  5. #5

    Join Date
    Jul 2009
    Location
    Texas
    Posts
    102
    +1
    11
    Check the throttle bore and butterfly. If there is a build up of gunk and/or carbon, the idle control won't be able to operate the throttle to maintain proper idle speed. Idle speed should be between 1200 and 1400 RPM and it should hold pretty steady.

  6. #6
    Stepper valve is responsible for idle. Ofter goes bad. New one $220

  7. #7
    Thanks for all the help guys. I will keep you guys posted thanks again

  8. #8
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,163
    +1
    602
    Quote Originally Posted by Skips313 View Post
    Stepper valve is responsible for idle. Ofter goes bad. New one $220
    buy some throttlebody cleaner/carby clean

    clean the TB
    also clean the IAC motor

    this will more than likely fix it

    Waz

    basicly clean the gunk u can see out , if you are not sure how to ,Take it to your local car mechanic as TB cleaning is a very normal prceedure they should do at each service.

    Should take no more than 10min tops

  9. #9
    ok guys cleaned out the tb and raised the idle a tad and wala the ski runs awesome! now another issue lol, the warning alarm keeps ringing at a very low tone. it dosent beep just rings, i think it has to be with the wiring because the ski is running perfect, water flowing fine full of gas no warning lights just that ringing. when you turn the steering wheel it rings louder or when you go in to and out of reverse the noise gets higher and lower. this leads me to believe it has to be a bad ground or a wire got moister? thanks guys!

  10. #10
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,163
    +1
    602
    Quote Originally Posted by boostin250x View Post
    ok guys cleaned out the tb and raised the idle a tad and wala the ski runs awesome! now another issue lol, the warning alarm keeps ringing at a very low tone. it dosent beep just rings, i think it has to be with the wiring because the ski is running perfect, water flowing fine full of gas no warning lights just that ringing. when you turn the steering wheel it rings louder or when you go in to and out of reverse the noise gets higher and lower. this leads me to believe it has to be a bad ground or a wire got moister? thanks guys!
    does sound like a floating earth or the like.

    just try to clean/tighten all earth circuts, and look for the obvious wiring damage in the area around the steering assy

    Waz

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GPR 1300R low idle
    By mjet in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 05-14-2013, 07:43 AM
  2. GP1300 low idle
    By 99will273 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 09-14-2010, 03:32 PM
  3. SLTX - hard start, low idle, 5200 rpm max -HELP!
    By ralt33 in forum Polaris PWC Performance
    Replies: 5
    Last Post: 06-20-2010, 09:35 PM
  4. New info SLTX - hard start, low idle, 5200 rpm max -HELP!
    By ralt33 in forum Polaris Open Discussion
    Replies: 18
    Last Post: 04-24-2010, 11:17 AM
  5. 1995 Wave Venture 700 Low idle speed adjustments
    By lpfdemt in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 09-01-2009, 04:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •