Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    SEADOO4ME's Avatar
    Join Date
    May 2007
    Location
    Virginia Beach, VA
    Posts
    32

    Angry LOW RPM's & Speed

    Hey guys, I need your help. I want to improve the performance of my 2005 RXT with a Stage I kit. I took the ski out to get a baseline and the best I could get was 7450-7500rpms and 59.5mph. Definitely a lttle off! I searched and found some common causes could be a worn wear ring and a slipping S/C. I replaced the wear ring and shimmed the S/C to 120 in/lbs. Today my best was 7600rpms and 60.4. I little improvement but not much. What else should I check? All you Speed Demons out there, any suggestions? One other thing, the motor is out of a 2004 RXP. My motor ate a valve and I got this one from a forum member when he parted out his 80+Stage III. Can heat and humidity effect performance this much?


  2. #2
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    Yes, heat and humidity can effect performance. Also check for a boost leak.

  3. #3
    masta2000's Avatar
    Join Date
    Aug 2009
    Location
    montreal-quebec
    Posts
    576
    +1
    1
    check your oil level; it has to be in between the two bends. even with good clutch you can get slippage with too much oil. check your plugs too. how many hours does the engine have?

  4. #4
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by SEADOO4ME View Post
    Hey guys, I need your help. I want to improve the performance of my 2005 RXT with a Stage I kit. I took the ski out to get a baseline and the best I could get was 7450-7500rpms and 59.5mph. Definitely a lttle off! I searched and found some common causes could be a worn wear ring and a slipping S/C. I replaced the wear ring and shimmed the S/C to 120 in/lbs. Today my best was 7600rpms and 60.4. I little improvement but not much. What else should I check? All you Speed Demons out there, any suggestions? One other thing, the motor is out of a 2004 RXP. My motor ate a valve and I got this one from a forum member when he parted out his 80+Stage III. Can heat and humidity effect performance this much?
    Wich wiring harness did you use?

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407

    Knock Sensor Update for 2004 Wire Harness


  6. #6
    SEADOO4ME's Avatar
    Join Date
    May 2007
    Location
    Virginia Beach, VA
    Posts
    32
    Masta
    The oil level is good - between the bend (ski level, checked 30 seconds after warm up). The plugs looked good - light tan in color. The ski doesn't miss or anyhing so I just reinstalled them. About 75 hours on the motor.

    Speedski
    The harness and ECU are the originals - 2005 RXT.

    Beerdart
    I read the thread about the knock sensor update but it says it pertains to early 2004 RXP ECU's. I'm using the 2005 RXT ECU. Could this still be the problem? I might just have to spend $40 and get the pigtail. If it works, that's money well spent! If not, it's only $40 bucks. My local dealer won't be open till Tuesday.

    Any other suggestions/ideas?? Keep em coming, I'll try anything once!!

  7. #7
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Quick test. Check the ohms between pin #1 and #2 on the knock harness it should read 1710-1890 ohms. As I recently found out on my 05 it did not have the resistors in the harness as I was lead to believe.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	2005 Sea-Doo Engine Service Manual.jpg 
Views:	68 
Size:	174.3 KB 
ID:	148121   Click image for larger version. 

Name:	2005 Sea-Doo Engine Service Manual_0001.jpg 
Views:	65 
Size:	716.8 KB 
ID:	148122  

  8. #8
    stl2slw's Avatar
    Join Date
    Mar 2008
    Location
    Hampton, VA
    Posts
    59
    what prop are you running? could be the problem

  9. #9
    SEADOO4ME's Avatar
    Join Date
    May 2007
    Location
    Virginia Beach, VA
    Posts
    32
    Beerdart - I checked the ohms between pins 1 & 2 of the knock sensor harness connector. It measured 23-24K ohms. I assume thats means I need the pigtail? I'll get one tomorrow if they have it in stock.

    stl2slw - I'm running the stock RXT impeller. I inspected it when I replaced the wear ring - it's good.

    I'll post up when I know something.

  10. #10
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Quote Originally Posted by SEADOO4ME View Post
    Beerdart - I checked the ohms between pins 1 & 2 of the knock sensor harness connector. It measured 23-24K ohms. I assume thats means I need the pigtail? I'll get one tomorrow if they have it in stock.

    stl2slw - I'm running the stock RXT impeller. I inspected it when I replaced the wear ring - it's good.

    I'll post up when I know something.
    Check it with connector "A" removed from the ECU and post results.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 stx 12f - low rpm and top speed
    By furn1593 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 32
    Last Post: 06-15-2013, 09:36 PM
  2. Low rpm & speed
    By Dnebe in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-18-2010, 10:51 AM
  3. Low RPM 7700 and Top Speed 70 with S3 and C5 SC's on 04 RXP
    By snowrunner in forum 4-Tec Performance
    Replies: 24
    Last Post: 06-23-2009, 08:54 AM
  4. low RPMS/Speed first 10 minutes?
    By Chris0060 in forum 4-Tec Performance
    Replies: 0
    Last Post: 05-25-2009, 05:31 PM
  5. New 04 RXP Low RPM & Speed
    By RXP04 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-02-2005, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •