Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    xplayer2885's Avatar
    Join Date
    Sep 2006
    Location
    LI, NY
    Posts
    1,251
    +1
    43

    Difficult time balancing out engine temp. I need help.

    The slt has the tripple pisser setup on it. I had 3 small restrictors in the lines. Engine was deffinatly overheating after 100 yard burst so I shut it down rite away. The water comming out was hot enough to burn you. I let it cool down an swam to shore an took out all the restrictors. Havent ran it since becuase I had to get towed back becuase I managed to get 2 outta 3 plugs nice an wet beucase I wanted to change over the the BPR8ES. Btw does the BPR8ES make the engine run any cooler?? Im having a bitch of a time getting the MAG cylinder to be even with the other two.


  2. #2
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    What sixe tube/fittings are you using? I tried 1/4 and it overheated. then went to 3/8 and it runs like a top

  3. #3
    AWA Member 32DegH2O's Avatar
    Join Date
    Aug 2006
    Location
    Minneapolis, Mn.
    Posts
    2,008
    +1
    5
    The lower the spark plug number the hotter the plug gets. BR9ES plugs will be cooler than the BPR8ES plugs.

  4. #4
    xplayer2885's Avatar
    Join Date
    Sep 2006
    Location
    LI, NY
    Posts
    1,251
    +1
    43
    Quote Originally Posted by seaobin View Post
    What sixe tube/fittings are you using? I tried 1/4 and it overheated. then went to 3/8 and it runs like a top
    Im pretty sure they are the fly racing brand. No real way of checking, the ski is at the marina. Anyway you can post a picture of your 1/4 an 3/8 restrictors?

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Why would you have a restrictor in the HOT cylinder?

    Try running a 3/8" fitting and hose for the Mag.

    Then run a 3/8" fitting and hose on the other 2 with a 1/4" I.D. restrictor in them. See what you get then.

  6. #6
    xplayer2885's Avatar
    Join Date
    Sep 2006
    Location
    LI, NY
    Posts
    1,251
    +1
    43
    Quote Originally Posted by xlint89 View Post
    Why would you have a restrictor in the HOT cylinder?

    Try running a 3/8" fitting and hose for the Mag.

    Then run a 3/8" fitting and hose on the other 2 with a 1/4" I.D. restrictor in them. See what you get then.
    X, i am running 3/8 fittings an 3/8 hoses. Does that mean I should just put in the 1/4 inch restrictors in the pto an center?

  7. #7
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    as cold as your water is, you should have the other issue if you are free flowing through 3/8" line. Mine runs cool and out lakes are almost 90* here in the summer
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	jet ski cooling2.jpg 
Views:	51 
Size:	2.02 MB 
ID:	148272  

  8. #8
    xplayer2885's Avatar
    Join Date
    Sep 2006
    Location
    LI, NY
    Posts
    1,251
    +1
    43
    Quote Originally Posted by seaobin View Post
    as cold as your water is, you should have the other issue if you are free flowing through 3/8" line. Mine runs cool and out lakes are almost 90* here in the summer
    Whats the other issue?? I can tell you im deffinatly not running lean by any strech. Im also baffled becuase on the hose this bad boy is runnin super cool, which basically makes no sense.

  9. #9
    seaobin's Avatar
    Join Date
    Jun 2007
    Location
    Raleigh, North Carolina, United States
    Posts
    1,573
    +1
    1
    other issue "is" running cool.

    I get about a 6' arc out of all of my pissers with no restrictors.

    If you are running hot when the pump is pushing water, that would tell me there is a blockage in the pump fittings or the main cooling line

    My ski has the flush on the main water line coming from the pump, becasue I do not have a water rail anymore. I use a lock plyer to clamp the cooling line behind the fitting

  10. #10
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,328
    +1
    29
    Quote Originally Posted by xplayer2885 View Post
    X, i am running 3/8 fittings an 3/8 hoses. Does that mean I should just put in the 1/4 inch restrictors in the pto an center?
    Yes.

    See what you get.

    FYI: the MAG will run hotter than the other 2 because of the added heat of the magneto.

    You should be able to cool it down to almost equal temps though.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Kaw Ultra 300x cutting out at 5k RPM. NEED HELP
    By Shelbyelite in forum Kawasaki PWC Performance (4-stroke)
    Replies: 90
    Last Post: 05-01-2012, 10:01 AM
  2. Engine Tempruter Alarm / Need Help
    By nmalfarhan in forum Yamaha PWC Performance (4-stroke)
    Replies: 12
    Last Post: 07-03-2011, 06:57 PM
  3. Installing RXP engine, had accident need help?
    By lawracing in forum Conversion PWC Performance Skis
    Replies: 51
    Last Post: 02-18-2009, 02:34 AM
  4. Engine moving around - need help!!!
    By reustic in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-03-2008, 12:28 PM
  5. ultra 150 engine vibratin alot need help!
    By jramos in forum Kawasaki How To & FAQs
    Replies: 8
    Last Post: 01-25-2008, 01:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •