Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524

    those with 04 RXP's or 04 RXP ECU's in conversion skis and are only getting 7600 rpm

    If your RPM are locked down at 7600-7700 RPM you need to install the knock sensor piggy back adapter part number 278002050

    The reason i bring this up is I've talked to 3 people already this week that have this issue so hopefully this info can help someone else.

    What happens is any time the ECU is hooked up to BUDS a knock sensor update is loaded to the ECU (this ONLY pertains to 04 RXP ECU's)

    In addition to flashing this update to the ECU the dealer is supposed to install a pig tail harness between your stock wire harness and knock sensor connector. If this is not done your RPM's will be locked down to 7600-7700 RPM's

    Hope this helps


  2. #2
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Well, thank you so much for explaining this to me today Jerry. I have been racking my brain wondering where I suddenly lost 300rpms. The motor ran 8100 when it was in the RXP. The motor only had 39 hours when I bought it.
    Installed it to do the conversion and it ran 7900rpms with a 14/21.5 pitch dynafly.

    So, I too it to the dealer to clear the pesky sensor and to clear the maintenance light. Well, from that point forward, I have not been able to pull the same RPMs as I did since March 3rd. I attributed it to either heat, humidity, ect....and even still too much pitch.

    Well, after seeing I could only muster up 7600-7650 rpms on occasion, with blips of 7700 if is came uphooked still had me baffled because I even depitched the impeller down to a 14/20.

    Well, after talking to Jerry about a 7600rpm mode discussed in Hallpass's thread, Jerry explained some things to me on how the 4-tec ECU works and the specifics on the 04 update. I assumed since my ski was an 04, it had the update. But nope, since it was a low hour ski (39 hours), it apparently has never been to the dealer to haev the BUDS plugged in for the software update.

    Well, my ECU finally got the BUDS plugged in when I took it in to have the VTS turned off. Well, JErry said, once an 04 get plugged in for the first time, after the update release, it automatically gets updated. But, if the knock sensor harness pigtail update is not done as well, the ski will no longer see the 8100 rpms it is suppose to. This was my problem the whole time.

    After talking to Jerry on the phone, he walked thru the process of locating the knock sensor connector and to see "if"I had the pigtail harness......nOPe....I did not have it. So, he provided me the part number and my local dealer had it for under 40.00.

    It is now installed and I am looking forward to testing it tomorrow if time allows. I have been battling these little gremlins now for months, but I am grateful to have the help of Jerry and this forum to figure things out.

    This may be a minor situation for some of you, but I am still learning this platform since doing this conversion.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	photo1.jpg 
Views:	396 
Size:	129.1 KB 
ID:	148371   Click image for larger version. 

Name:	photo2.jpg 
Views:	457 
Size:	85.4 KB 
ID:	148372   Click image for larger version. 

Name:	photo3.jpg 
Views:	496 
Size:	101.1 KB 
ID:	148373   Click image for larger version. 

Name:	photo5.jpg 
Views:	504 
Size:	113.0 KB 
ID:	148374   Click image for larger version. 

Name:	photo6.jpg 
Views:	435 
Size:	98.8 KB 
ID:	148375  

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by RX-Pike View Post
    I wonder if this is what's happening to my ski... It's an 04' and since the 10 hour check-up, haven't seen 7600+ unless out of the hole.
    I can almost guarantee this is your issue. At the 10 hour checkup the ski was hooked to BUDS. The update was flashed to the ECU automatically and the dealer didn't install the pigtail harness.

    I help people solve this issue nearly on a weekly basis thru PM or email so i figured i would post it here in open forum again.

    Get the knock sensor update harness i listed above.... problem solved

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by dhoad View Post
    Jerry helped me out with the same issue. I went from the rotax ECU to the riva and never had good #s until I installed the knock sensor piggyback.
    glad this helped you Doug!


    Just for future reference for anyone reading this thread.

    If you use the Rotax Racing ECU you DO NOT want the piggy back harness installed.

    If you are using the stock ECU or RIVA ECU you MUST have the piggy back harness installed.

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Quick test. Check the ohms between pin #1 and #2 on the knock harness with connector "A" removed from the ECU it should read 1710-1890 ohms.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	2005 Sea-Doo Engine Service Manual.jpg 
Views:	2576 
Size:	174.3 KB 
ID:	148381   Click image for larger version. 

Name:	2005 Sea-Doo Engine Service Manual_0001.jpg 
Views:	3136 
Size:	716.8 KB 
ID:	148382  
    Last edited by beerdart; 08-31-2009 at 07:23 PM.

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    After doing some digging and resistance checks on my 05 I found out that the update also affects 05 models. The engine harness part number 420664951 is used on.

    Where Used: [420664951 (Engine Wiring Harness Ass'Y)]
    Challenger 180 4-TEC SCIC, 2005
    Challenger 180 4-TEC TOWER, Edition 1, 2006--
    Challenger 180 4-TEC, Edition 1, 2006
    Challenger CS TOWER, Edition 1, 2006
    Challenger CS, Edition 1, 2006
    GTX 4-TEC, LTD SCIC, 2005
    RXP, 2004
    RXP, 2005
    RXT, 2005
    Sportster 4-TEC SCIC, 2005
    Sportster 4-TEC SCIC, Edition 1, 2006

  7. #7
    i have rxp07 and only have 7650 rpms. do i need the knock sensor piggy back adapter part number 278002050?

  8. #8
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    no

  9. #9
    i changed my ecu coz i accidentally damaged it. would it be possible that i got a replacement ecu for the 04rxp thus making me need the part discussed above?

    i'm asking this coz i run 7650 and never saw my rpm hit above 8000 since i got my unit.

  10. #10
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    your ski wouldn't even run with an 04 ecu on it... much different technology and electrical setup. so i would rule that possibility out.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 06-03-2010, 01:37 AM
  2. those with 04 RXP's or 04 RXP ECU's in conversion skis and are only getting 7600 rpm
    By Green Hulk in forum Conversion PWC Performance Skis
    Replies: 1
    Last Post: 07-25-2009, 05:24 PM
  3. 04 RXP only hitting 7600 rpm
    By snowrunner in forum 4-Tec Performance
    Replies: 12
    Last Post: 06-29-2009, 08:21 PM
  4. It sucks with the RXP-X order in Europe
    By branix in forum 4-Tec Performance
    Replies: 2
    Last Post: 10-15-2007, 08:46 AM
  5. Will a RXP ECU work in a 04 GTX-SC?
    By OsideBill in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-29-2007, 04:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •