Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    1996 SL900 & SL700 turk0004's Avatar
    Join Date
    Jul 2007
    Location
    Chicago IL
    Posts
    328

    Thanks again guys!

    My SL900 fired right up tonight. Received my rebuilt crank from Jeff @ Midwest Crankshaft on friday. Took most of the day saturday to reassemble the engine. Had musclehead neighbor drop it back in for me yesterday. Finished all the other stuff including alignment using my newly created alignment tool based on beerdart's specs. Fired up on the first try.

    You guys are the best!

    Turk


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275

  3. #3
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407

  4. #4
    785 Pro Mick's Avatar
    Join Date
    Sep 2006
    Location
    Homer Glen, IL
    Posts
    700
    Next step, see how it runs in the water. Keep us posted

  5. #5
    Bing-A-Ding-Ding-Ding, Brrrrrap! Brrrrrrrrrap!!! Polaris_Nut#1's Avatar
    Join Date
    Aug 2006
    Location
    Pittsfield, MA
    Posts
    3,350
    +1
    26
    nice to hear good news

  6. #6
    1996 SL900 & SL700 turk0004's Avatar
    Join Date
    Jul 2007
    Location
    Chicago IL
    Posts
    328
    Quote Originally Posted by 785 Pro Mick View Post
    Next step, see how it runs in the water. Keep us posted
    yep! that happens on friday...fingers are crossed

  7. #7
    Pain is fear leaving your body.... rlovebk's Avatar
    Join Date
    Aug 2008
    Location
    So. Cal.
    Posts
    5,206
    +1
    511
    Good luck!! Good for you. I miss riding my SLT like mad. Should be back up in a week or 2 though. Time is hard to find sometimes. Congrats and have fun!

  8. #8
    1996 SL900 & SL700 turk0004's Avatar
    Join Date
    Jul 2007
    Location
    Chicago IL
    Posts
    328
    Hey guys. The 900 is running great! No leaks, jugs feel perfect and running about 6400 RPM. Can't thank you guys enough!

    Turk

  9. #9
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Quote Originally Posted by turk0004 View Post
    Hey guys. The 900 is running great! No leaks, jugs feel perfect and running about 6400 RPM. Can't thank you guys enough!

    Turk
    Sure you can!!!!!

    Pics of the ski with a Hotty riding it woiuld be thanks enough....

  10. #10
    Pain is fear leaving your body.... rlovebk's Avatar
    Join Date
    Aug 2008
    Location
    So. Cal.
    Posts
    5,206
    +1
    511
    Quote Originally Posted by xlint89 View Post
    Sure you can!!!!!

    Pics of the ski with a Hotty riding it woiuld be thanks enough....
    +1, +2, +3, etc. Right on Kevin!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 03-21-2012, 08:01 PM
  2. Need a little help again guys
    By volleybug in forum MSX/Matrix
    Replies: 0
    Last Post: 07-16-2008, 09:51 PM
  3. Thanks Again Ben.....
    By peteshauling in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 07-09-2008, 10:44 PM
  4. Thanks Again Green Hulk
    By paramuir in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-15-2008, 12:00 PM
  5. Thanks again Jake Speed
    By Dr Len in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-15-2007, 07:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •