Results 1 to 8 of 8
  1. #1

    97 GTX running too rich

    I have a 97 sea doo gtx. I just rebuilt the carbs. The VRO was disconneted when I bought it. I set the low speed needles at one turn and the high speed one at 0 and the other one at 1/2 turn from closed. Thats the factory settings. My question is should de mixture be 50:1 or is that too rich? Cause I as smoking like crazy and my plugs are coming out very oily. HELP!


  2. #2

    Join Date
    Jun 2007
    Location
    Sacramento CA
    Posts
    58
    I think the oil pump de-faults to full oil when disconnected. IF thats all they did then thats the problem

  3. #3
    jcancel's Avatar
    Join Date
    Apr 2009
    Location
    Sunrise, FL
    Posts
    64
    welcome to the greenhulk

    sorry i cant help but here are a lot of people with experience that will help you.. I Believe his oil tank is empty he is premixing on the gas tank i dont believe the oil pump is connected...

  4. #4
    If you just disconnect the pump cable, you will get no oil. The stock ratio at WOT is 40:1. At idle throttle, its about 200:1, hence the smoke difference.

  5. #5
    Quote Originally Posted by jwick86 View Post
    If you just disconnect the pump cable, you will get no oil. The stock ratio at WOT is 40:1. At idle throttle, its about 200:1, hence the smoke difference.
    Makes perfect sense. So should I go to 60:1 or even 70:1 to try to lean out the mixture a bit or leave it at 50:1????

  6. #6
    Deanrw3's Avatar
    Join Date
    Oct 2008
    Location
    west MI
    Posts
    249
    40:1 if you are using seadoo oil or you will be out of oil when you run WOT.

    welcome to premix....enjoy the smell.

  7. #7
    I guess Ill try to reconnect the VRO. Does anybody know somebody in south florida that still works on 2 strokes.

  8. #8
    dghal's Avatar
    Join Date
    Jul 2008
    Location
    League City Texas
    Posts
    280
    just put a block off plate on there and premix some 93 octane premium with a quality oil and enjoy riding

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stx 1100 running too rich
    By NCrunner2012 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 7
    Last Post: 06-12-2016, 02:19 PM
  2. '04 RXP Seadoo stage 3 Fuel Problem running too rich
    By Woody49 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 08-18-2012, 06:09 AM
  3. my 97 gtx wont stay running on water
    By provo in forum 2-Stroke Performance
    Replies: 2
    Last Post: 03-01-2011, 09:15 AM
  4. 97 SeaDoo GTX runs out of water but no power & max rpm @ 3200 in water
    By Irish Democrat in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-14-2009, 09:00 AM
  5. Can I post GTX stuff too....lol
    By two2curupt in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-14-2005, 10:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •