Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    Jul 2005
    Location
    Southampton, UK
    Posts
    190

    Engine trouble... or not - confused!

    Have owned a 2005 RXT from new, covered 90 hours total. Ski is stock, except for OPAS lifters and Riva grate.
    At the 50hr service, we had bad leakdown test results, but didn't worry because we had "babied" the ski from new - running it in slowly (yes, I know!!!)! Just had a 100 hour service (10 hours early) and the results are even worse!! 12, 18,16. This is the sign of a bad engine!!!! The leakdown results this time are approx 4 points worse than last time.
    The strange thing is that the engine pulls strong. We went to the lake to specifically evaluate performance after the service. Initially 7800 rpm, then took out 1L of oil and back up to "usual" 8100 rpm / GPS 65.5 mph before we had to shut off (Lakes are small in the U.K.!)- could have probably got more speed. Literally thrashed the life out of her for 1 1/2 tankfuls, she didn't miss a beat - no oil consumption, ran round the course at 7500 plus rpm consistently, peaking at over 8000 on the "straights". Pulled inlet pipe off SC afterwards and it was absolutley clean - no oil reisdue. And yet, if you listen to what they say, the engine is on its last legs and has been for over 40 hours (since the first test at 50 hours).
    Sorry about the long post BUT what do you think? How meaningful is the leakdown test when we get this performance consistently? The dealer did say that based on the performance of our Ski, we should not worry about the results - I have to say we are happy with it in every way and it compares well in races with similar Skis.


  2. #2
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,185
    +1
    98
    Leak down is a good test, but in this case, a compression test may be in order to see it it corrilates the leak down results.

  3. #3
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    its under warranty so run it till the end of the the year.

  4. #4

    Join Date
    Jul 2005
    Location
    Southampton, UK
    Posts
    190

    Still confused

    I will do a compression test to see what that shows.

    I think that our "problem" is that we ran it in slowly? My confusion comes round to the fact that our Ski is definitley not a slow one (and matches other RXTs easily), and we don't have any significant oil use - our N/A 4-Tec used more!. With the poor results, you might expect it to be down on performance and using oil?

    We have run it for 40 hours with this "issue", with no problems apparent - but looking at the manual, we should be getting ready for an engine strip! Is it possible that the way an engine is run in can produce OK ring seal in normal operation, but poor leak down results?

  5. #5
    I stole my dads ski RXT_IAN's Avatar
    Join Date
    Feb 2006
    Posts
    131
    Anyone else have any leak down test resulst from their skiis?

  6. #6

    Join Date
    Jan 2006
    Location
    Rydal, Georgia U S A
    Posts
    3,936
    +1
    14
    Valves are leaking... They need to be reground, But, If you bitch a little a good dealer will get you a new head.

  7. #7

    Join Date
    Jul 2005
    Location
    Southampton, UK
    Posts
    190

    Rings

    I wondered about that, but the dealer said they can tell where the leakage was coming from (I seem to remember somthing about this when I re procedure originally) and he said it was the rings! Strange!

  8. #8

    Join Date
    Jul 2005
    Location
    FL
    Posts
    3
    The new Sea-Doo shop manual says 0% to 15% excellent condition and 16% to 25% good condition, and 26% to 40% is fair condition. So at your leak down rate you should not be to worried. I do know that the older Sea-Doo manuals state that 0% to 7% excellent 8% to 15% fair and 16% to 30% poor condition. So I wonder why early manuals say one thing and later manuals say another??????

  9. #9

    Join Date
    Jul 2005
    Location
    Southampton, UK
    Posts
    190

    Happy and less confused!!!

    I have the older manual!
    You have just made me a happy man !
    NOW, we can start modding!

  10. #10

    Join Date
    Jul 2005
    Location
    FL
    Posts
    3
    Just wanted you to have the facts

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 06-11-2014, 06:38 PM
  2. WTB complete 4-tec engine running or not.. NA or SC
    By JPR in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 03-23-2011, 04:21 PM
  3. rude 2 running 50lb injector will damage engine or not ?
    By hendyho in forum 4-Tec Performance
    Replies: 9
    Last Post: 09-27-2009, 07:26 PM
  4. 1996 SLTX To Pull The Engine or Not To Pull The Engine
    By 1996SLTX in forum Polaris Open Discussion
    Replies: 70
    Last Post: 06-27-2007, 02:15 PM
  5. Sbc Good engine or not, if not where to go???
    By gvnitup in forum Polaris Open Discussion
    Replies: 17
    Last Post: 04-22-2007, 09:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •