Results 1 to 8 of 8

Thread: Loosing RPM

  1. #1

    Loosing RPM

    Thanks In advance....Loosing RPM on my 2007 Kawasaki Ultra LX changed the spark plugs and still nothing checked by the impeller area to see if anything got sucked up nothings there. The ski sounds like it blew something what can it be? I cant pass 10MPH @6000rpm any ideas anyone?


  2. #2
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Sounds like you may have blown a Hose off the intercooler or exhaust..........

  3. #3
    Thanks Ill check it out

  4. #4
    Rocket Power !!! Spin21's Avatar
    Join Date
    Mar 2009
    Posts
    215
    Drain bolt under fuel rail? Thin, small black vacume hose that connects throttle body to blow off valve? SC belt slipping due to lube on it or being too lose?

  5. #5
    Beagleman62's Avatar
    Join Date
    Mar 2007
    Location
    Richmond, Virginia
    Posts
    2,726
    +1
    64
    The guy said he has an LX..... no s/c belt, no I.C. or blow off valve.

  6. #6
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,994
    +1
    455
    Quote Originally Posted by Beagleman62 View Post
    The guy said he has an LX..... no s/c belt, no I.C. or blow off valve.

    hahahah

    I agree with Jim.

  7. #7
    Rocket Power !!! Spin21's Avatar
    Join Date
    Mar 2009
    Posts
    215
    Quote Originally Posted by Beagleman62 View Post
    The guy said he has an LX..... no s/c belt, no I.C. or blow off valve.

  8. #8
    2005 RXT Red08Ultra250's Avatar
    Join Date
    Feb 2008
    Location
    Dunedin, FL
    Posts
    908
    it gets confusing now with the ultra 260 LX.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Speedster 155hp looses rpm turning
    By Norm123 in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-07-2015, 11:57 AM
  2. 2008 sho loosing rpm and running lean
    By MR MAC in forum Yamaha PWC Performance (4-stroke)
    Replies: 17
    Last Post: 05-08-2014, 09:59 PM
  3. 05 RXP ECU loosing rpm
    By benGTST in forum Sea Doo ECU Support
    Replies: 20
    Last Post: 01-13-2014, 02:29 PM
  4. loosing rpms
    By southernstateofmind in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 04-23-2013, 08:24 AM
  5. Loosing RPMs....help
    By johnD in forum 4-Tec Performance
    Replies: 19
    Last Post: 05-29-2006, 03:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •