Results 1 to 2 of 2
  1. #1

    Salt buildup on engine

    OK, so last weekend I came home from the beach but, for the first time, I didn't completely wash the seadoo. I only sprayed the engine area down with Salt Terminator and flushed the engine since I knew I was going to the lake this weekend. Yesterday, I noticed major salt (or some white residue) all over the engine area. Since I'm not a mechanic, I don't know what things are called. I wiped away most of what I could see with a wet washcloth, but there is some residue around the corners of the supercharger area that I can't get to. I'm gonna wash it thoroughly today. How can I clean this area?


  2. #2
    rangermtb5's Avatar
    Join Date
    Apr 2008
    Location
    North Jersey
    Posts
    4,473
    +1
    58
    Quote Originally Posted by sea_major View Post
    OK, so last weekend I came home from the beach but, for the first time, I didn't completely wash the seadoo. I only sprayed the engine area down with Salt Terminator and flushed the engine since I knew I was going to the lake this weekend. Yesterday, I noticed major salt (or some white residue) all over the engine area. Since I'm not a mechanic, I don't know what things are called. I wiped away most of what I could see with a wet washcloth, but there is some residue around the corners of the supercharger area that I can't get to. I'm gonna wash it thoroughly today. How can I clean this area?

    wash it down with the salt terminator again, then cover the ENTIRE engine bay with Fluid Film, or similar product. there is nothing you can't spray it on. it will prevent salt damage and keep the inside looking sweet. you really should do this after every ride in salt. also, i like to spray the rideplate, pump, intake grate, prop, OPAS, basically everything metal that is exposed to water.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Salt water on engine after riding. RXPX300
    By rxp_boy in forum 4-Tec Performance
    Replies: 19
    Last Post: 08-23-2016, 04:23 AM
  2. salt on engine gti 130 a chronic problem
    By Fabiano in forum 4-Tec Performance
    Replies: 6
    Last Post: 01-02-2012, 10:30 PM
  3. LOOSE PIPE ON ENGINE!!(metal not rubber).
    By English Bob in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 11-26-2007, 04:39 PM
  4. Putting S/C back on engine
    By zone 5 in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-15-2007, 06:23 PM
  5. Marks on engine hoist hooks
    By USS RXT in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-08-2005, 12:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •