Results 1 to 9 of 9
  1. #1

    2004 VirageI Service Manual

    Am new to the Forum and am glad I found you.

    My 04 VirageI has quit after many years of excellent service. It has been running a little rough and this weekend it quit while the Grandchildren were here.

    It has little to no spark at the plug and the plugs are wet after cranking. Before I start replacing Ignition components I would like to do some isolation.

    My problem is I cannot not find a source for a Service Manual anywhere on the Web.

    I will appreciate your assistance in locating such manual, thks.


  2. #2
    mr. happyfunbear tenjuna's Avatar
    Join Date
    Jun 2009
    Location
    Davenport, IA
    Posts
    574
    pm me.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Welcome

    Are you seeing any red lamp or warning messages on the display?

    Is the spark weak on both spark plugs?

    If the plugs are wet with fuel, that implies the CPS is working, the injector voltage is at least usable, and the EMM is alive.

    You can find some useful info here;
    Polaris Ficht Fuel Injected Engines

  4. #4
    Sorry for the silence but have been very busy. I did find a Service Manual for a 2003 ViragI ($12 to download).

    I worked on it some and found the 3amp fuse for the Bilge Pump blown. Pulled the Pump and it is frozen. Will get a new one tomorrow and replace before I go further.

    I am curious, does the Ski have to have the Bilge Pump running in order to run the Ski??? I see the diagram for the wiring external to the LR module and was wondering if the Ski has to sense Bilge Pump current to start???

    I will replace it tomorrow and try to start it, if that fails I will go thru the readings listed in the SM.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by weewun View Post
    ...I worked on it some and found the 3amp fuse for the Bilge Pump blown. Pulled the Pump and it is frozen. Will get a new one tomorrow and replace before I go further.

    I am curious, does the Ski have to have the Bilge Pump running in order to run the Ski??? I see the diagram for the wiring external to the LR module and was wondering if the Ski has to sense Bilge Pump current to start???

    I will replace it tomorrow and try to start it, if that fails I will go thru the readings listed in the SM.
    There is no requirement for the bilge pump to operate. It is separate from the EMM (fuel injected engine).

    This is a fuel injected two cylinder Virage, or carburetor?

  6. #6
    It is a 2004 Virage I two cylinder Fuel Injected.

    It started running rough and then hard to restart. The spark is weak for both cylinders. Battery is new this year and fully charged. Motor cranks at normal speed but will not start.

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by weewun View Post
    It is a 2004 Virage I two cylinder Fuel Injected.

    It started running rough and then hard to restart. The spark is weak for both cylinders.

    Battery is new this year and fully charged.

    Motor cranks at normal speed but will not start.
    Could be several things, but my guess is the EMM.

    Confirm that battery voltage is well above 10.5 volts while cranking.

    Check the ignition coils for correct ohms, and clean up the coil grounding to the heads.

    Check the voltage on the White/Red wire that feeds the injectors (with both injectors still plugged in). It is supposed to be over 20 volts while cranking, and jump to near 45 volts when the engine is running.

    Check the CPS sensor ohms. Should be under 200 ohms, typically around 140 ohms.

  8. #8
    Sorry about the delay in responding but the weather has been terrible.

    K447 I did the tests you suggested as well as thos in the Service Manual, everything was within specs. Received the new bilge pump today and installed it and replaced its fuse. It started up and ran. Go figure.

    Am going to solve the problem by getting two new SeeDoos and park this one.

    Thks for the input.

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by weewun View Post
    ...found the 3amp fuse for the Bilge Pump blown. Pulled the Pump and it is frozen...

    I am curious, does the Ski have to have the Bilge Pump running in order to run the Ski???

    I see the diagram for the wiring external to the LR module and was wondering if the Ski has to sense Bilge Pump current to start?...
    Quote Originally Posted by K447 View Post
    There is no requirement for the bilge pump to operate.
    It is separate from the EMM (fuel injected engine)...
    Quote Originally Posted by weewun View Post
    ...Received the new bilge pump today and installed it and replaced its fuse.

    It started up and ran. Go figure...
    Well, that was not the outcome I expected

    Something odd going on in there, if simply replacing the bilge pump and bilge fuse solves the problem of weak spark and no-start

    ...goes off to review Ficht two cylinder wiring diagram...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB 2004 rxp service manual
    By thatdude596 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 03-23-2013, 08:40 AM
  2. Replies: 2
    Last Post: 10-03-2009, 02:46 PM
  3. Need 2004 stx 1200f service manual
    By arise in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 08-14-2009, 09:28 AM
  4. 2004 15F Service Manual
    By trinityracing in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 09-07-2008, 08:26 AM
  5. RXP 2004 Service Manual book (pdf)
    By branix in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-29-2007, 01:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •