Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Join Date
    Jan 2008
    Location
    Canada
    Posts
    93

    96 seadoo gsx no start

    Ok long story short. I was out with my jet ski and everything is perfectly fine. Any how, i hookup my seadoo to my rented pontoon boat, then 1 of the drivers made a sharp turn on the pontoon and flipped my jet ski. So now my jet ski is full of water. Anyways i tow the jet ski back on the pontoon and to my trailer to drain the water out because it has full of water and no start. I drained all the water. Still no start. Now it seems like the battery is weak. I have a trigger charge and have always charged my yuasa battery. Sometimes i get 2 beep and sometimes i get 1 beep. Sometimes there's no beep, but u still hear something near the speakers. I dunno if there is something wrong with that little beeping speaker. Now there is no start and it just clicks. It doesn't even crank. It clicks 1 or 2 clicks and that's it. Would my starter be no good? Maybe there are water everything. I sucked all the water from the fuse box and the vts. What could be the problem?
    It just clicks once or maybe twice the most and that's it. It doesn't crank over.
    Hope this is an easy fix because i know water got into the engine and crap. Thanx for the help.


  2. #2
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    cylinders are probably full of water, take the heads off. check your battery connections and get all that water out ASAP

  3. #3

    Join Date
    Jan 2008
    Location
    Canada
    Posts
    93
    Is there a crankcase bolt that i can lose off underneath to drain any water. I have took out the plugs, cranked it and lots of water came out. I also put a air hose and blow it out and a lot of water came out. Still there is water inside. The only way is to take the head out? Would that take out all the water inorder for it to start. Hopefully someone can help. Thanx.

  4. #4
    dghal's Avatar
    Join Date
    Jul 2008
    Location
    League City Texas
    Posts
    280
    Since this happened yesterday your clock is rapidly ticking down on getting the water out, ( RUST ) is all ready happening in there.
    To my knowledge there is not a drain plug anywhere on them, pulling the head will not get water out of the crankcase,


    You need to roll the ski over a few times, while the plugs are out and crank the motor in intervals. once it gets to the point that it is just some water vapor you need to get it fired to (dry ) and lubricate the internals.

    Also How fast were you towing it on the "rented" pontoon boat?? It was most likely full of water in the exhaust from towing. You MUST pinch off the pump line when you tow.

    good luck,, but hurry on getting it dried and fired...

  5. #5

    Join Date
    Jan 2008
    Location
    Canada
    Posts
    93
    I have another problem now. I got it fired up. Battery was weak. Now when i hookup the garden hose, i see leak. There was no leak before. Anyways i have fixed the leak already. I got another issue. I hook up the garden hose, then when i try to start it, it is full of water in the plugs and everything and now it won't start. It is inside the carb and stuff also. What could be the problem when i hookup the garden hose, the water is getting inside the engine.

    I have played around with this plunger valve near the exhaust. Could that be the problem? I dunno what it is, but above the exhaust there is like this black plunger piece with the clip and there is a spring inside. I saw water leaking there, so i fixed it. Then after i try to get it to run, the water is inside the cylinders again. It wasn't like that before i touch that valve plunger. Hope someone can help me thanx.

  6. #6

    Join Date
    Jun 2007
    Location
    Sacramento CA
    Posts
    58
    Are you turning on the water hose before starting the engine ?
    If so that is your problem. You must have the engine running before the hose is turned on otherwise the water spray feed to the pipe will flood it and the engine.

  7. #7

    Join Date
    Jan 2008
    Location
    Canada
    Posts
    93
    Thanx for that reply. That really helped. I turned on my water hose before i started the jet ski. I will remember this forever.

  8. #8
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Yes. Always engine on, then water. Then water off, then blow out residual 3 times minimum @ wot, then engine off.

  9. #9

    Join Date
    Jan 2008
    Location
    Canada
    Posts
    93
    I've got a real problem now. Sometimes i am getting spark and sometimes not. Could that be the ignition coil? I want to be sure it is the ignition coil. All the wiring is not broken and i have checked. I did have water inside the fuse box, so that could mess up the coil. Hope someone can help.
    The coils is $112 plus tax in Canada. If that is the problem i will buy it.

  10. #10

    Join Date
    Jan 2008
    Location
    Canada
    Posts
    93
    So shall i order the coil? Or could it have something to do with the ignition key or something. Sometimes my key beeps once, but most times it beeps twice. At this time i don't get spark all the time, but sometimes i do.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 seadoo GSX no spark.
    By rxpx2008 in forum 2-Stroke Performance
    Replies: 5
    Last Post: 09-26-2009, 04:48 PM
  2. 96 Seadoo GSX, 787cc
    By firebird67 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-04-2009, 06:08 PM
  3. 96 GSX no Start!!! Lil Help
    By GSXRYDER in forum 2-Stroke Performance
    Replies: 15
    Last Post: 11-03-2008, 08:19 AM
  4. 96 seadoo gsx problems.
    By rxpx2008 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-07-2008, 10:06 AM
  5. 96 seadoo gsx not pulling right
    By jetskigreg in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-20-2007, 08:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •