Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 49
  1. #1
    S12L00X's Avatar
    Join Date
    Sep 2006
    Location
    S.E. Michigan
    Posts
    168

    2000 Pro 1200 Drive Shaft Issue

    Was out this past weekend on my pro and went to take off and something on my drive shaft (i think) stripped out. It started to go and then it made kind of a loud nosie and the engine was running fine but it wasnt going anywhere. It just made king of a loud grinding noise while it was running. I had it towed back in and took it apart tonight. The drive shaft doesn't look like anything is worn on it. I started it up without the drive shaft and it doesn't make the noise anymore. I can't figure out how to get that coupler off the back of the motor. I put my finger in it to see if i could feel anything stripped out but it seems fine. Just need to take it off so I can look inside of it to see if I can see anything. Any help would be great.

    Thanks,
    Dave


  2. #2
    AWA Member 32DegH2O's Avatar
    Join Date
    Aug 2006
    Location
    Minneapolis, Mn.
    Posts
    2,008
    +1
    5
    With the pump off and the drive shaft out, shine a strong light into the drive shaft hole and you should be able to look into the drive coupler without removing it. I assume you checked the splines on the impeller as well?

  3. #3
    S12L00X's Avatar
    Join Date
    Sep 2006
    Location
    S.E. Michigan
    Posts
    168
    Yeah all the splines look good. I checked both ends of the drive shaft and the impeller. I justed looked at it with a flashlight and it looks like the coupler is stripped out. Any idea on how to get it off?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276

  5. #5
    S12L00X's Avatar
    Join Date
    Sep 2006
    Location
    S.E. Michigan
    Posts
    168
    Thanks for the info. I will have to pick up some 3/8" rope and give it a try. When you say cover up the ports you just mean the exhaust port right? I am going to try and get it off tomorrow or Thursday. Anyone have a used one for sale or know where I can find one. They are $260 new.

    Thanks

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    John Zigler is a good source, and check the Classifieds for folks parting out skis or selling parts.

    Polaris PWC Parts Sources

  7. #7
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    What works better than rope is a bungy cord.

    And you don't want the rope going into the port openings. It will make the piston rock inside the cyl and put alot of stress on the piston side-ways.

  8. #8
    Watcon's Avatar
    Join Date
    Oct 2005
    Location
    Seattle WA
    Posts
    872

    Driveshaft

    I have a new one in stock..

  9. #9
    AWA Member 32DegH2O's Avatar
    Join Date
    Aug 2006
    Location
    Minneapolis, Mn.
    Posts
    2,008
    +1
    5
    If the coupler is stripped...or if anything else got stripped, you need to try and find out why it stripped so it doesn't happen again to a new/replacement part.

  10. #10
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,777
    +1
    405

    grease

    the pro1200 has a shorter spline engagement at the coupler end,maybe an inch long.so shorter engagement length,135 hp,solid coupler,no grease.bingo!!!

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. pro 1200 drive shaft and engine coupler
    By prodaddy1200 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-05-2012, 11:05 PM
  2. 2000 Pro 1200 issues
    By CrazyBill in forum Polaris PWC Performance
    Replies: 6
    Last Post: 06-13-2012, 07:42 PM
  3. FS 1200 pro hardened drive shaft
    By castaicsportsgarage in forum Polaris Classifieds
    Replies: 4
    Last Post: 03-10-2012, 02:11 PM
  4. 2000 Pro 1200 random issue on shut off
    By eah026000 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-30-2010, 03:14 PM
  5. 2000 slx 1200 drive shaft
    By tburn in forum Polaris Classifieds
    Replies: 2
    Last Post: 07-24-2008, 08:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •