Results 1 to 8 of 8
  1. #1
    PWC Newbie
    Join Date
    Aug 2009
    Location
    Sweden
    Posts
    29

    How I fixed my Info Center

    I recently bought a GSX Limited -98 quite cheap, reason being that it's in quite bad shape. The Info Center did function intermittently, more when I was riding it on the sea.

    I checked the important power supply cables which were good, and even when I connected the gauge directly to another battery it didn't work. So I opened the gauge itself.

    The solder joints inside had been corroded by water and my thought was that I just could resolder the joints that looked bad. I did, but it still didn't work. After some measuring with an ohm-meter(?) I found out that a lane on the circuitboard was corroded to the point that it almost was completely off. My solution was to solder a wire between the incoming power wire and the solder joint on the board where the broken lane ended. See the attached picture for details.

    It's just a tip for those who ride around with skis without working Info Centers...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC00398.JPG 
Views:	71 
Size:	58.6 KB 
ID:	149763  


  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Welcome to the Forum!

    Great info! thanks for sharing...thats what this forum is all about.

  3. #3
    PWC Newbie
    Join Date
    Aug 2009
    Location
    Sweden
    Posts
    29
    Thank you!

    I have been reading a lot of posts and gotten so much info from this forum so I wanted to contribute in some way as well. Hopefully someone is helped by this info!

  4. #4

    Join Date
    Jul 2005
    Location
    Ohio
    Posts
    441
    +1
    1
    Nice job

    TLR

  5. #5
    how did you get the board out of the enclosure?

  6. #6
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Good job! Very nice diagnosis work.

  7. #7
    Quote Originally Posted by hermie View Post
    how did you get the board out of the enclosure?
    anyone?

  8. #8
    PWC Newbie
    Join Date
    Aug 2009
    Location
    Sweden
    Posts
    29
    Sorry, didn't see your question.

    I had to bend a steel ring open, it holds the transparent glass to the rest of the black body. It broke a little bit, so I sealed it with silicone when I put it together. Unfortunately it didn't get waterproof, so I had to take it out and reseal it again!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. how to check info center on 1997 gsi
    By hardhead in forum Sea Doo How To & FAQs
    Replies: 1
    Last Post: 09-08-2013, 08:30 PM
  2. Hole in my Hull!?!? How to fix
    By nd4spdbh in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-20-2013, 08:13 AM
  3. Seadoo Shop doesnt know how to fix my RXT...Oil Warning alarm
    By kaorder1999 in forum 4-Tec Performance
    Replies: 26
    Last Post: 06-29-2010, 07:45 PM
  4. How to fix a rip in my ski cover?
    By JonnyRXT in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-01-2009, 11:03 PM
  5. How I fixed my MFD
    By christian79 in forum Polaris Open Discussion
    Replies: 28
    Last Post: 07-23-2007, 07:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •