Results 1 to 6 of 6

Thread: 95 Wave Venture

  1. #1

    95 Wave Venture

    Pulled plugs and turned over to check for fuel flow. Turned over and am not able to see any gas at all pumping in, bone dry. Carbs freshley rebuilt. Started and ran fine on hose but died out after 1 minute of riding in water. Will not restart.

    Suggestions on fuel source problem?

    Thanks,


  2. #2
    dghal's Avatar
    Join Date
    Jul 2008
    Location
    League City Texas
    Posts
    280
    so what lead up to this,, trace back the steps,,

    things to check

    tank is full,
    fuel selector valve is on,
    pulse line on pump,


    Do you have choke plates or a primer ?
    if plates a splash of fuel down the fogging holes might get it fired up.

    do you pre mix? the pump can "oil log" and it may need to be opened up and cleaned out

    water seperator is not full of crud?

  3. #3
    Thanks for the response. This has progressively gotten worse. There is fuel in the tank and the selector is on and free and clear. I have choke plates and do not pre-mix. I have tried fuel down the carbs but does not work.

    What is this "pulse line on pump"? Don't mean to sound dumb but is this the fuel line on the carburator or is there an external fuel pump located somewhere on the ski.

    Thanks again for the help.

  4. #4
    L Carlson's Avatar
    Join Date
    Aug 2007
    Location
    Bonita Springs, Florida, United States
    Posts
    7,118
    +1
    2
    Check your compression. in each cyl. and repost your #'s

  5. #5
    I will check compression and respond.

    Thanks,

  6. #6
    dghal's Avatar
    Join Date
    Jul 2008
    Location
    League City Texas
    Posts
    280
    pulse line is on the intake side of the motor and runs to the fuel pump.. when the piston travels up and down a pulse is made and the diaphram it the pump moves and draws fuel, a broken,pinched,or collapsed line could cause you syptoms,

    BUT a splash of fuel down the carb bores should light the motor up, atleast until that fuel is burned up///

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 wave venture bogging! HELP!!
    By Larry 597 in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 08-31-2009, 07:01 PM
  2. 95 Wave Venture 701
    By lpfdemt in forum Yamaha Old School Skis
    Replies: 4
    Last Post: 08-22-2009, 11:36 PM
  3. 95 wave venture idles, wont go over 7mph. Help!!
    By Larry 597 in forum Yamaha Old School Skis
    Replies: 4
    Last Post: 08-17-2009, 03:59 PM
  4. '95 Wave Venture
    By repoman in forum Yamaha Old School Skis
    Replies: 16
    Last Post: 07-20-2008, 10:08 PM
  5. 95 wave venture whining noise
    By ayersrsa in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 07-07-2008, 07:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •