Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    never ending charging issue for my rxp 2007 215hp HELP!!

    hi guys, i have a 2007 rxp 215hp, first time i took it out i rode for 15 mins and got stuck on the river with a flat battery, i took it to my mechanic and he gave me a brand new battery and installed a brand new starter motor telling me that was the problem. so i took it out the other day.. and the same bloody thing happened again.. went out for 15 mins turned it off then on, rode a bit and then boom no battery.. he also said its charging fine. so what the hell could it be?? THEN i took it to him again, he replaced the battery and replaced some little black box that looks like a audio amplifier i forgot what its called,the mechanic said everything that charges the ski is FINE nothing is working out of order..

    SO, i took it out straight away after i got it from the mechanics.. and i can bloody hear it dying in the ass again.. wtf is the problem!

    I Have come up with a theory and please all u gurus correct me if im wrong. since my engine is newly rebuilt, the person i bought it off said the engine is a bit TIGHT and after u ride it a bit it will loosen up, my mechanic said if its not the charging issue it would be the engine is using up too much charg/power to turn it around (which sounds like its too tight to turn..) he also scared me a bit n said it could be your crank or bearings.. but i doubt it cause the ski runs fine doesnt sound like its got any hiccups happening or anything..

    so heres my theory. since i havnt had a good day out with it. im thinking of taking a battery booster pack with me, go for a whole day of jetskiiing and see how we go. could this be the problem to this stupid ass mystery?
    please someone correct me if ive gone mad but what else would it be? i asked him about the fuse box being corroded with salt he said it wouldnt be the problem either way because its responding etc etc. so yeh.. this is where im at.
    rami


  2. #2
    Gus13letter's Avatar
    Join Date
    Apr 2008
    Location
    Tampa Bay, FL
    Posts
    8,135
    +1
    822
    Hmm, that is odd. Did he put a load tester on the battery prior to putting it in the ski to make sure the battery was good? If the system is charging then you shouldnt have any issues. Sounds like something may be shorting out causing the exta battery drain or causing the battery to go bad quickly.

  3. #3
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    charging system or battery.

    If you've replaced one....

  4. #4
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    im no ski mechanic god but i would say if your mechanic told you the motor was too "tight" causing your battery to go dead/not charge, i'd burn rubber out of that shop and try another

  5. #5
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Quote Originally Posted by Mike H View Post
    im no ski mechanic god but i would say if your mechanic told you the motor was too "tight" causing your battery to go dead/not charge, i'd burn rubber out of that shop and try another
    +1 If your mechanic is agreeing with your "engine is tight and using extra juice" theory find a new mechanic.

  6. #6
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    If It labors turning over with a new battery, and starter, then the timing could be off (too far advanced), or off by a tooth even. And when it gets hot it gets even harder to turn over. As for the charging issue, put a meter on the battery while running on the hose, and rev around 5500 rpms Should get 13.5+ volts. If above 15+volts the rectifier is bad. Check all your fuses, for blown, melted, or corroded contacts.

  7. #7
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    First, find a new mechanic. A guy who just replaces parts without diagnosing the problem first should be avoided. Haveing said that I would check for loose grounds, and + bat connections. Is the charging voltage above 13.5v? Does the 12v low indicator show up on the dash? Will it still crank after it dies? Answering these questions will point us in the right direction

  8. #8
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    3,879
    +1
    116
    Something doesnt seem right here New batt, new starter, charging sytem is fine, tight motor with fresh rebuild and some guy who seem to know zero about seadoo's. If it were me id check compression then double check the timing. You could also pull the driveshaft and spark plugs out and see if it turns over easy

  9. #9
    Quote Originally Posted by Mike H View Post
    im no ski mechanic god but........ i'd burn rubber out of that shop and try another
    That's funny as shit ......

    Hope you figure it out dude.GL

  10. #10
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    charging sytem is fine,
    How did "Mr engine too tight" determine this...

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GPS for my RXP ?
    By cr1421 in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 04-12-2006, 08:59 AM
  2. Got my IR Plugs for my RXP. Do I have to wait?
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-21-2005, 11:07 AM
  3. Look what I just won for my RXP! I think it was a steal.
    By Water4fire in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 06-07-2005, 09:56 AM
  4. Got new parts for my RXP???
    By muskadoo in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-30-2005, 10:57 AM
  5. Looking for a nice seat cover for my RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 16
    Last Post: 05-23-2005, 06:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •