Results 1 to 4 of 4
  1. #1
    lacfiremx02's Avatar
    Join Date
    Aug 2005
    Location
    Boothwyn, Pennsylvania
    Posts
    9

    2003 GP1300R Not Running To Well

    My friend has a 2003 GP1300R and it used to hit up to 80MPH but now it only reaches 50-60 tops.. You have to stay on the throttle the whole time or else it will bog out. Any ideas on what could be wrong with the ski?


  2. #2
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,800
    +1
    449
    Quote Originally Posted by lacfiremx02
    My friend has a 2003 GP1300R and it used to hit up to 80MPH but now it only reaches 50-60 tops.. You have to stay on the throttle the whole time or else it will bog out. Any ideas on what could be wrong with the ski?
    80 on the Dreamo ? Carbs or EFI ? Engine mods ?

  3. #3
    Mr Bill's Avatar
    Join Date
    Aug 2005
    Location
    Macon Georgia
    Posts
    451
    Does he have a D plate?

  4. #4
    ABBOTT's Avatar
    Join Date
    Jul 2005
    Location
    Birmingham, AL / Lay Lake
    Posts
    3,736
    +1
    96
    Give us more info. Then after we all help you, go ahead and change your signature. LOL --just messin with ya.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Just bought a 2001 Polaris SLX 1200cc. Not running well any fixes?
    By Crash_6565 in forum Polaris PWC Performance
    Replies: 22
    Last Post: 08-07-2014, 02:57 PM
  2. 2003 gp1300r not running right
    By garathv in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 01-12-2009, 12:19 PM
  3. FS:2003 Yamaha AR210, Not happy to sell, but here she is.
    By espritonsevas in forum Performance Boats Classifieds
    Replies: 0
    Last Post: 08-10-2008, 09:09 PM
  4. FS:2003 Yamaha AR210, Not happy to sell, but here she is.
    By espritonsevas in forum Yamaha Classifieds
    Replies: 0
    Last Post: 07-16-2008, 09:35 PM
  5. GP1300R not performing from mid to high
    By scuubby in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-27-2008, 08:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •