Results 1 to 5 of 5
  1. #1
    96 slt 780
    Join Date
    Sep 2009
    Location
    austin , texas
    Posts
    9

    polaris slt 780 having problems!!!

    im having problems with my polaris slt 780.... it starts up just fine and runs very good when your driving strait. if i start turning the handle bars back and forth it starts to sputter and it will die sometimes... it will also die if i jump waves or turn to fast... it always starts up no problems though... does anyone have any idea what is causing this to happen?? i would really appreciate it if someone could help me out !!! my email is [email protected] or... just write me on here!!! thanks


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Welcome to the Hulk..
    Sounds like a fuel delivery issue.

  3. #3
    96 slt 780
    Join Date
    Sep 2009
    Location
    austin , texas
    Posts
    9
    the thread part that you screw the gas cap on was cracked and i think it has water in the gas tank..... i just dont know though... has this ever happened to you or anyone else before?? if it did... what was the problem??

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Quote Originally Posted by jeepdude82 View Post
    the thread part that you screw the gas cap on was cracked and i think it has water in the gas tank..... i just dont know though... has this ever happened to you or anyone else before?? if it did... what was the problem??
    Yes water in the fuel will cause problems.

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Welcome to the Hulk Jeep.

    Check your water seperator for the water intrusion.

    Also make sure that your engine grounds are good, clean, and tight.

    Is there a piece of plastic between the battery and the elec box? There should be.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 polaris slt 780 ignition problem!?!?!?!
    By Ghostrider55 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 07-04-2015, 12:33 PM
  2. Replies: 14
    Last Post: 07-26-2014, 06:11 PM
  3. 96 Polaris slt 780 ignition problems
    By dodge in forum Polaris Projects
    Replies: 15
    Last Post: 08-13-2012, 06:22 PM
  4. 1996 Polaris SLT 780 - MFD Gauge Problems
    By cvrs492 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 05-02-2011, 09:49 PM
  5. 96 Polaris SLT 780 Salt/Fresh Water & Digital Display problem
    By pastordug in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 08-07-2009, 03:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •