Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 37
  1. #1
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113

    Questions about open loop cooling

    Im thinking about going open loop so i can use the Riva open loop plate. Im just courious about any problems with going open loop. I ran in salt water all the time. is there anything i have to worry about as far as the salt through the motor or the temp of the motor? diff gauges i would need to keep an eye on the temp? any feedback would be very helpful for my decision! thanks

    Justin


  2. #2
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Get JD1s kit set it up just the way his diagrame says, no need to watch temps unless you riding in extreme conditions He says that he has tested from 40 to 90 degrees which covers most people i would think.

    Make sure you flush every ride and use some Dawn Liquid when you do its the same as salt away and helps to get the salt out the engine ect ect. R88

  3. #3
    blowbyu's Avatar
    Join Date
    Jun 2006
    Location
    San Antonio, TX
    Posts
    635
    Whatever kit you get make sure to place an inline water control valve to control engine temps.

  4. #4
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by blowbyu View Post
    Whatever kit you get make sure to place an inline water control valve to control engine temps.
    Y?? Les Cooke from seadoo centre and JD have been running open loop just like this since 2004 without any valves, The engine temp will change a little with diff conditions but JD has already said it has not and will not cause issues. There are a good few race boats here in UK that run OL all year round, no valves required. Our water is like 30 degrees in the winter and 65 in summer so we are never all that warm. R88

  5. #5
    blowbyu's Avatar
    Join Date
    Jun 2006
    Location
    San Antonio, TX
    Posts
    635
    Yes, understood.

    I and a few others here in Texas are running Dan's water routing and we are running valves. If I do not have valve in place the hottest temps seen are 130 @ WOT.

  6. #6
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by blowbyu View Post
    Yes, understood.

    I and a few others here in Texas are running Dan's water routing and we are running valves. If I do not have valve in place the hottest temps seen are 130.
    OK fair 1 I dont have much testing with it just what I have seen at the races ect ect. I know that a few have said that ideal temps are in the 160-170 area. R88

  7. #7
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    thanks for the feedback guys...keep it coming!

  8. #8
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by blowbyu View Post
    Yes, understood.

    I and a few others here in Texas are running Dan's water routing and we are running valves. If I do not have valve in place the hottest temps seen are 130 @ WOT.
    What did you with your pump restrictor? Anything?

  9. #9
    blowbyu's Avatar
    Join Date
    Jun 2006
    Location
    San Antonio, TX
    Posts
    635
    Quote Originally Posted by jtskier11 View Post
    What did you with your pump restrictor? Anything?

    Nothing.... Dont need anymore water coming into the boat. More water = cooler temps.

  10. #10
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by blowbyu View Post
    Nothing.... Dont need anymore water coming into the boat. More water = cooler temps.
    So why does Dan not seem to have a problem but you are? Just asking.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question about open loop cooling
    By Cutter in forum 4-Tec Performance
    Replies: 36
    Last Post: 07-16-2009, 07:13 PM
  2. open loop cooling question
    By DaveC in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 09-09-2008, 06:14 PM
  3. Open Loop Cooling Question
    By suck my wake in forum 4-Tec Performance
    Replies: 40
    Last Post: 08-17-2008, 05:01 PM
  4. Open Loop Cooling question.
    By lafjax in forum 4-Tec Performance
    Replies: 4
    Last Post: 02-04-2008, 06:39 PM
  5. water intake for open loop cooling question
    By lee in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 11-10-2007, 09:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •