Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1

    Need some help 07 250X

    I got a 07 250X blowing oil out of the top catch can filter.113 hours on the motor.I jump a wave the boat started missing and the oil light came on .I shut the motor off and got towed in.Took the seat off and there was oil every where.Added some oil to the motor and started it back up.I have alot of blow bye coming out the filter. Thanks AZLawson


  2. #2

    Cool How big was the wave if you don't mind me asking?

    Quote Originally Posted by AZLawson View Post
    I got a 07 250X blowing oil out of the top catch can filter.113 hours on the motor.I jump a wave the boat started missing and the oil light came on .I shut the motor off and got towed in.Took the seat off and there was oil every where.Added some oil to the motor and started it back up.I have alot of blow bye coming out the filter. Thanks AZLawson
    Must have been a hell of a wave or something was wrong to begin with. I am always jumping yacht waves (up to '4 waves) on my '07 250X and have never had any issues (knock on wood). I am currently @ 130hrs...

  3. #3
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,563
    +1
    169
    was the dip stick out? who did the last oil change? was the filter tight? did one of the fittings come off the catch can?

  4. #4
    kman's Avatar
    Join Date
    Aug 2007
    Location
    Labrador
    Posts
    193
    Why do you have a filter on the top of the catch can? This port is supposed to route back to the intake so that this oil gets sucked back into the intake rather than all over your ski. Do you have GIO? If so, did you block the catch can drain or install the drain valve. If an excessive amount of oil got back to the catch can and the drain line to the crankcase was blocked then this would explain what happened. It would also explain why the oil light came on. Your oil including any blowby filled the catch can and then started coming out of the filter. The wavejumping also would have helped this oil movement into the catch can.
    Remove the filter on top of the catch can and route it back to the intake as it's supposed to be. You also want to drain the catch can after each ride (if the drain is blocked) and check your oil level before each ride. If you're going to be doing lots of wave jumping and you have the catch can drain blocked, I would add a drain port about midway up the catch can back to the crank as others on this site have done. Just do a search for "catch can".

  5. #5
    Quote Originally Posted by AZLawson View Post
    blowing oil out of the top catch can filter
    How is that a filter?
    Isn't it more like a oil/fume separator? Oil drains back into the engine and fume goes into the air intake.

  6. #6
    Rocket Power !!! Spin21's Avatar
    Join Date
    Mar 2009
    Posts
    215
    I think Kman's got it. You jumped a big wave and at some point the rear portion of the head became the low point dumping oil into the can. Not a big deal unless ur bottom drain is plugged and the oil cant get back into the engine. Oil light comes on, ski misses....sounds about right. A lil bung welded about 1.5 inches above the drain is what you need. Reconnect the drain hose to that so if you dump alot of oil into the can most of it will drain back and not starve the engine.

  7. #7
    JET250's Avatar
    Join Date
    Jan 2008
    Location
    Australia mate fair dinkum.
    Posts
    1,278
    +1
    2
    empty the can, if it still happens, do a compression test. any noises from the engine. I hope you get off the throttle during flight, I have been vertical more then once and never had a drama.

  8. #8
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    Quote Originally Posted by meangreenman View Post
    How is that a filter?
    Isn't it more like a oil/fume separator? Oil drains back into the engine and fume goes into the air intake.
    obviously he is using the riva bypass kit that causes the said issue

    get rid of the filter off the top of the can as suggested by others replace with the oem hose to the intake.

  9. #9
    Quote Originally Posted by nicjak View Post
    obviously he is using the riva bypass kit that causes the said issue

    get rid of the filter off the top of the can as suggested by others replace with the oem hose to the intake.
    Okay guys here we go 15 hours on a oil change alittle gas in the oil.Yes it is a Riva filter kit.Yes I used the ome hose at the end of it I put a filter.The waves are boat waves not very big at all.The dip stick is all the way in.I got home and hooked it up to the water hose and ran it I had alot of blow by coming out that filter.No I dont like all the oil dumping back into my air box and into my inter cooler.I droped it off at the dealer on Tuesday to get it checked out.I think something let go in the motor it still runs but it sounds like it is only running on 3 cylinders.My guess is that something in the vavle train is not right .Thanks for all the input we will see today what it is. AZLawson

  10. #10
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    you still didn't say whether your catch can has the bottom hose blocked off? of course you are going to have blowby it runs from your rocker cover this is where your crankcase breathes from, the air has to go somewhere by putting a filter where you have you are venting it to your hull of course its going to be messy when your catch can takes in some oil. guessing you do have issues now but also guessing it may have been overfilled jmpo. most people i know run the hose and we don't dump oil into our i/c.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Looks like I goy a bad 07 RXP, I need some help.
    By jasen 2007 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 07-24-2012, 10:22 AM
  2. Need setup help - 07 250X
    By The Big Mastuda in forum Kawasaki PWC Performance (4-stroke)
    Replies: 15
    Last Post: 12-23-2008, 06:23 PM
  3. Need some help guys, Lost 500rpm
    By CRS in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-15-2006, 05:24 PM
  4. Need some help ?
    By RXP04 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 04-20-2006, 04:36 PM
  5. SeaDoo 3D (need some help)
    By MARKUS in forum 2-Stroke Performance
    Replies: 21
    Last Post: 02-09-2006, 05:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •