Results 1 to 5 of 5
  1. #1

    Has anyone tried this??????

    These website sells it and they have an ebay store and sell it cheaper... http://www.carperformance.us/index.p...&termek_id=666 ...you guys think its safe to try????


  2. #2
    krispaintballz's Avatar
    Join Date
    Sep 2007
    Location
    Kenosha, WI
    Posts
    2,978
    Junk it doesn't do anything! Just helping you out.

  3. #3
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    I wouldn't use one. I would like to cut one open to see what is (not) in it.

    IMO likely just a clamp or filter for a signal which will not take other variables into consideration.

    I love the high quality connectors. {sarcasm}

  4. #4

    Join Date
    Oct 2006
    Location
    melrose ma
    Posts
    411
    RUN AWAY....RUN AWAY

  5. #5
    Looped's Avatar
    Join Date
    Jun 2009
    Location
    So Cal
    Posts
    262
    looks like it is probably a resistor or a rheostat... dunno.. I'd stay away from that thing.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 160 mm prop has anyone tried this.
    By JOSE13RT in forum 4-Tec Performance
    Replies: 7
    Last Post: 10-14-2007, 06:54 PM
  2. Has anyone tried this?
    By GP1300R powerhouse in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-20-2007, 09:31 AM
  3. So has anyone tried this?
    By Lvnspeed in forum 4-Tec Performance
    Replies: 31
    Last Post: 04-02-2007, 08:01 AM
  4. Has anyone tried this...?
    By RXP-REX in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-09-2006, 06:50 PM
  5. Brainstormin, has anyone tried this?
    By VOODOO in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 04-29-2006, 04:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •