Results 1 to 7 of 7

Thread: Water

  1. #1

    Join Date
    Jul 2006
    Location
    Owensboro, KY
    Posts
    109

    Water

    Just curious but after every ride when I open the drain plugs on the trailer I get a pretty good stream of water out of the back end for about 30 seconds then it is done.... Does this sound about right or should it be dry??? Just curious as to what everyone else is seeing.


  2. #2
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    807
    i see a little drip for about 5 seconds

  3. #3
    THE OFFICAL SUPERDUTY!!!!!! superduty's Avatar
    Join Date
    May 2006
    Location
    Webster, Texas
    Posts
    4,726
    +1
    5
    how hard do you play in the water the seat does not do the greatest sealing the top and the air intake on the front of the seat will let in alot of water it you splash alot

  4. #4

    Join Date
    Jun 2006
    Location
    toronto
    Posts
    965
    Little dribbles if I'm on alone and have not used my bilge. Little bit more if passenger on back and not used bilge. Using bilge in large surf, little bit.

  5. #5
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    807
    Quote Originally Posted by superduty
    how hard do you play in the water the seat does not do the greatest sealing the top and the air intake on the front of the seat will let in alot of water it you splash alot
    i always get wet, i jump waves, i ride with me only almost always, i leave the ski in the water weeks at a time and still manage to have only a little water.

  6. #6
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    Quote Originally Posted by badams7
    Just curious but after every ride when I open the drain plugs on the trailer I get a pretty good stream of water out of the back end for about 30 seconds then it is done.... Does this sound about right or should it be dry??? Just curious as to what everyone else is seeing.
    I had the same thing. Removed the carbon seal and everything related, looked for damage...didn't see any.....and put it all back together. No water from teh plugs now, I think something just wan't seated correctly or not tight enough.

  7. #7

    Join Date
    Jul 2005
    Location
    SE Texas
    Posts
    396
    +1
    3
    Greetings--

    After a day of hard riding, we'll get a 20-30 sec stream of water running out the plugs. We don't have pumps. No leaks noticed around the drive shaft so.... no worry eh .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Proper salt water protection
    By CRAZEDRXP in forum Sea Doo How To & FAQs
    Replies: 23
    Last Post: 02-07-2010, 06:23 PM
  2. Water Box Mod
    By Red Devil in forum 4-Tec Performance
    Replies: 27
    Last Post: 05-17-2005, 04:56 PM
  3. RXP-Taking on water
    By RXPDAVID in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-10-2005, 06:44 AM
  4. Finally in the water
    By Sunfunzoom in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-09-2005, 08:07 AM
  5. Replies: 1
    Last Post: 04-30-2005, 10:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •