Results 1 to 2 of 2

Thread: Limp Mode

  1. #1
    Asmarine's Avatar
    Join Date
    Jun 2009
    Location
    Lakeland FL
    Posts
    33

    Limp Mode

    2001 MSX 110 is in limp mode and has oil in the coolant res any ideas and the temp light comes on after a few seconds?


  2. #2
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,483
    +1
    83
    Hi Asmarine,

    Oil can ingress from a couple of places, can you give us a bit of history leading up to this event (ie weed in pump, running too long out of the water). Even with oil contamination I would not expect the temp light to come on in a 'few seconds' so we may be looking at a sensor fault as well. Need to hook up a pressure gauge to the cooling system and check for pressure leak down and or build up.

    Cheers

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Limp mode on a 97 STS.
    By ccassone in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-29-2009, 07:43 AM
  2. limp mode solutions/ suggestions on 95 slx
    By slxcrazy in forum Polaris How To & FAQs
    Replies: 14
    Last Post: 05-06-2007, 10:39 PM
  3. gas level limp mode ?
    By Bone1050 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 03-22-2007, 06:58 PM
  4. limp mode
    By tommy33mac in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 03-21-2007, 09:23 PM
  5. limp mode vs over of fuel
    By andy95'slx780 in forum Polaris PWC Performance
    Replies: 1
    Last Post: 10-02-2006, 04:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •