Results 1 to 2 of 2

Thread: Limp Mode

  1. #1
    Asmarine's Avatar
    Join Date
    Jun 2009
    Lakeland FL

    Limp Mode

    2001 MSX 110 is in limp mode and has oil in the coolant res any ideas and the temp light comes on after a few seconds?

  2. #2
    Kosh's Avatar
    Join Date
    Sep 2007
    Hi Asmarine,

    Oil can ingress from a couple of places, can you give us a bit of history leading up to this event (ie weed in pump, running too long out of the water). Even with oil contamination I would not expect the temp light to come on in a 'few seconds' so we may be looking at a sensor fault as well. Need to hook up a pressure gauge to the cooling system and check for pressure leak down and or build up.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. limp mode help please
    By karl1 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-22-2007, 04:53 PM
  2. Rxp In Limp Mode
    By BGslugger in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-09-2007, 06:42 PM
  3. Limp mode?
    By tinselhair82 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-22-2007, 11:24 PM
  4. limp mode
    By tommy33mac in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 03-21-2007, 09:23 PM
  5. limp mode vs over of fuel
    By andy95'slx780 in forum Polaris PWC Performance
    Replies: 1
    Last Post: 10-02-2006, 04:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts