Page 1 of 20 1 2 3 11 ... LastLast
Results 1 to 10 of 194
  1. #1

    Join Date
    Jul 2007
    Location
    PDX - Oregon
    Posts
    2,205

    What the hell is going on with my oil???

    I think the open loop cooling is messing up my ski due to not monitoring the water temps , but would like to know if it could be anything else.

    I, on the water, checked my oil and got it perfect on the d stick.... Not this ride a couple rides ago.

    Today, I ride 20 miles and the catch can is full. I check the oil and it is way high on the dip stick.

    I empty the catch can, ride another 20 and oil is still high but catch can is damn near empty. I ran WOT for quite a while on this ride and when I let off my ski had a continuous beep with oil flashing on the screen. I gave it a little gas and the ski sputtered a few times bit continued to run and beep. I turned it off and started it back up no problems at all....

    I ride another 20 miles and now I'm at the end of my ride so I start tearing it up doing donuts launching off my wake etc.... Catch can is full now and the d stick reads almost perfect!?! WTF?? The catch can fluid was very thin.

    Do a couple high speed runs and the oil is back up on the d stick. Catch can is barely full.

    HELP.....




    Sent from my iPhone using Tapatalk


  2. #2
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    sounds like you are cold. What is your engine temp?

  3. #3
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    I bet the oil looks very thin on the stick as well It's full of fuel

  4. #4
    AKA "The Guppy" JeffTurbo601's Avatar
    Join Date
    May 2007
    Location
    Jacksonville, Florida
    Posts
    991
    i posed the same question after running my ski for the first time with the open loop set up, my buddy and i had the same issue. heres what was said....
    http://www.greenhulk.net/forums/showthread.php?t=106402

  5. #5

    Join Date
    Jul 2007
    Location
    PDX - Oregon
    Posts
    2,205

    Re: What the hell is going on with my oil???

    Quote Originally Posted by Hydrotoys
    sounds like you are cold. What is your engine temp?
    Well, flame away on this one as I guess I am a sucker for someones word. I don't know the water temp because I have no gauge. I was told the kit was dialed.

  6. #6

    Join Date
    Jul 2007
    Location
    PDX - Oregon
    Posts
    2,205

    Re: What the hell is going on with my oil???

    Quote Originally Posted by bigdaddyRXP
    I bet the oil looks very thin on the stick as well It's full of fuel
    Yep..... Thin on the stick. Nice to know I could spend over 100 on the amsoil synthetic just to piss it out of the catch can......

  7. #7
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    It is starting to sound like open loop cooling is NOT the way to go unless you have a HIGHLY modified ski. It seems like many others are having problems like yours.

    Im glad others like you have tested before I did this LOL.

    I realize Dan and them are experts but could it be that they didnt plan these kits for near stock skis?

  8. #8
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    yeah, a cheapo $30 engine temp gauge duct taped to your dash to tune it in is pretty easy. Once your done, remove it, and never look at it again.

    Before ripping it apart, why don't you try it, and see what temp is coming out of the engine.

    Do you have the temp sensor on the input side of the water, or where it leaves the engine?

  9. #9
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    Quote Originally Posted by pdxrealtor View Post
    Well, flame away on this one as I guess I am a sucker for someones word. I don't know the water temp because I have no gauge. I was told the kit was dialed.
    not to be nasty BUT why cry wolf now bro..........u also said u werent adding a water temp gauge and u were good with being the GUINEA PIG if i remember correctly.........i can find the post if u like.................guess right about now a water temp gauge EVERYONE said u needed would have been great!!!!!!!!!!! PERIOD!!!!!!!!!!!

  10. #10
    AKA "The Guppy" JeffTurbo601's Avatar
    Join Date
    May 2007
    Location
    Jacksonville, Florida
    Posts
    991
    wow reid tells us how you really feel......BET!!

Page 1 of 20 1 2 3 11 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 10
    Last Post: 04-28-2016, 04:45 AM
  2. what the hell is going on with me 07 rxp!? only 70.8 mph?!
    By bksbigboy69 in forum 4-Tec Performance
    Replies: 31
    Last Post: 03-31-2012, 07:45 AM
  3. what the heck is going on with my ski?
    By sschne62 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 05-03-2009, 07:38 PM
  4. What the hell is going on in Dubai!
    By MikeTrin in forum Open Discussion
    Replies: 4
    Last Post: 12-29-2006, 09:15 AM
  5. What the H*** is going on with my GPR!!!
    By carbuff91 in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 05-31-2006, 05:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •