Results 1 to 9 of 9
  1. #1
    ronnierxp's Avatar
    Join Date
    Jun 2006
    Location
    macon, georgia
    Posts
    80

    my stage 1 results

    i only managed 65.8. witch sucks cause i hit 66.7 stock. i can only pull 7400 rpms but i did really notice a huge jump in acceleration with the stage one. im thinking my clutch washers need to be trashed and replaced with metal ones. what do you guys think? i need re block offs cause it porpoises like a bitch unless i got it just right


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Ronnie, you have something going on because you should be at 8100 RPM's.

    Overfilled oil?
    Slipping clutch?
    Worn wear ring?

  3. #3
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    by any chance did you put a 15/20 on it? because mine came with a 15/20 on an otherwise stock ski and I did not go over 7400 until I put a stock prop back on. now at 8100

  4. #4
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339
    Yeah, yeah- 7400 = NG.

  5. #5

    Join Date
    Jun 2006
    Location
    toronto
    Posts
    965
    Mine went from 8450 to 7900 due to two things 15/20 prop (and my boat has more power then average boat) and clutch not shimmed properly. 7900 for about 20 min. and slowly lost rpm down to 6400 when sc no longer ingageing. I use Rotax washers.

  6. #6
    ronnierxp's Avatar
    Join Date
    Jun 2006
    Location
    macon, georgia
    Posts
    80
    the box said 14/19r. its got a new wear ring. i dont know if it has the knock sensor update but im going to send pics to shibs today

  7. #7
    ramnj's Avatar
    Join Date
    Apr 2005
    Location
    New Jersey
    Posts
    1,713
    Quote Originally Posted by Green Hulk
    Overfilled oil?

  8. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by ronnierxp
    the box said 14/19r. its got a new wear ring. i dont know if it has the knock sensor update but im going to send pics to shibs today
    The knock sensor update on the 04 RXP was 2 part.

    1) flash update to the ECU
    2) Installation of a piggy back wire harness between the knock sensor connector and the stock wire harness.

    If only 1 of the two parts were done your RPM's will only be 7400. I bet this is your problem

  9. #9
    ronnierxp's Avatar
    Join Date
    Jun 2006
    Location
    macon, georgia
    Posts
    80
    i took it to the lake today to mess around and kept hitting 7450 rpms and holding them. i decided to check my oil and it was half an inch over the top bend. i got the oil straightened out and managaged to get 7750 rpms. im about to pull the supercharger off. how do i check the slipage.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My initial test results MaptunerX stage 1 SHO
    By Rock918 in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 05-23-2016, 11:48 AM
  2. My stage 2 RXP, 75.5+mph at 7900 rpms, yahoo!
    By Vern in forum 4-Tec Performance
    Replies: 23
    Last Post: 06-21-2006, 11:10 PM
  3. Riva Stage 1 Results...
    By Desldog in forum 4-Tec Performance
    Replies: 16
    Last Post: 08-09-2005, 01:40 PM
  4. Riva's Stage 2 results!
    By INDY27 in forum 4-Tec Performance
    Replies: 29
    Last Post: 07-11-2005, 03:38 PM
  5. So do we have any Riva Stage 2 Results yet?
    By Compwhiz82 in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-20-2005, 11:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •